Bug 186169 - Could not connect to Evolution Exchange backend process: No such file or directory
Could not connect to Evolution Exchange backend process: No such file or dire...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 18:31 EST by Andrig Miller
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.6.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-21 17:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ethereal trace file when running evolution (1.28 KB, application/octet-stream)
2006-03-28 09:29 EST, Dominic Harvey
no flags Details
Trace file of firefox using ethereal to the same server (4.06 KB, application/octet-stream)
2006-03-28 09:33 EST, Dominic Harvey
no flags Details

  None (edit)
Description Andrig Miller 2006-03-21 18:31:11 EST
Description of problem:

After upgrading from Fedora Core 4 to Fedora Core 5, my Evolution Exchange
account stopped working.  When I log in, I don't get an error, but I get the
following message when I try to expand the folder tree, I get the following error:

Error while Scanning folders in "Exchange server mail.navisite.com".

Could not connect to Evolution Exchange backend process: No such file or directory

Now, when I first tried to get it I also would get a failed to authenticate
message.  I deleted the account, and exited Evolution.  Then I started Evolution
again, and setup the mail account again.  Then the failed to authenticate
message seems to have gone away, but I still get the above message.  

Version-Release number of selected component (if applicable):

Evolution 2.6.0


How reproducible:

Happens every time.

Steps to Reproduce:
1.Start Evolution
2.Enter password
3.Expand folders for account
  
Actual results:


Expected results:


Additional info:
Comment 1 Andrig Miller 2006-03-23 22:30:40 EST
I started evolution from the command line to see if any error messages are
coming out there, and I get the following:

[andrig@localhost ~]$ evolution
CalDAV Eplugin starting up ...

** (evolution:3455): WARNING **: Unexpected kerberos error -1765328230

** (evolution:3455): WARNING **: Unexpected kerberos error -1765328230
[andrig@localhost ~]$ evolution
CalDAV Eplugin starting up ...

** (evolution:3475): WARNING **: Unexpected kerberos error -1765328230

** (evolution:3475): WARNING **: Unexpected kerberos error -1765328230

I showed it twice, so that you could see that the evolution:xxxx was difference
each time, but the number that follows the WARNING message is always the same. 
I don't know if this is related, but it is the only additional thing I have been
able to come up with.
Comment 2 Dominic Harvey 2006-03-27 21:36:30 EST
I have the same problem.

I trace the network with ethereal and i discover that the GET is using my valid
userid/passwd credential but i have and access denied.

I think our Exchange server dont accept Evolution as a valid User-Agent in the
THHP request.

I notice in the e2kcontext.c that a claim_ie is available but i dont know how to
use it.

I have the trace with me  if you want i send it to you

Hope it help
Comment 3 Dominic Harvey 2006-03-28 09:29:43 EST
Created attachment 126907 [details]
ethereal trace file when running evolution
Comment 4 Dominic Harvey 2006-03-28 09:33:24 EST
Created attachment 126909 [details]
Trace file of firefox using ethereal to the same server
Comment 5 Dominic Harvey 2006-03-28 09:39:08 EST
In those attached files, you will see that when i connect to the exchange server
with firefox it works but with evolution it did'nt.  The only difference is the
User-Agent in evolution.  Maybe evolution can fake a firefox browser to Exchange
server

Sorry for my english
Comment 6 Brad Laue 2006-04-06 00:08:12 EDT
The issue isn't with the user agent; any user agent can connect to Exchange, and
there are no filters.
Comment 7 Brad Laue 2006-04-06 00:10:38 EDT
I suppose I should add, I'm also having this issue - I'm using Exchange 2003

Evolution packages in question are:

evolution-connector-2.6.0-1
evolution-data-server-1.6.0-1
evolution-2.6.0-1
Comment 8 Brad Laue 2006-04-09 11:47:16 EDT
One other datapoint:

From a fresh account in Evolution, creation of the account leads to the folders being downloaded from the 
Exchange server, and after a few attempts they will display contents of e-mail messages, calendar events 
and tasks in evolution very briefly, then the exchange backend will crash. I'll get some console output 
momentarily.
Comment 9 Dominic Harvey 2006-04-14 14:53:54 EDT
look at this
http://bugzilla.gnome.org/show_bug.cgi?id=335561
Comment 10 Maxwell Bottiger 2006-05-18 09:35:04 EDT
I too am having this problem after upgrading from fedora 4 to fedora 5.  I'm
quite sure that nothing has changed on the exchange server side since this
worked yesterday.  I think it might be worth taking a look at where evoultion
thinks it can find the backend process and what socket it uses to talk to it. 
That sort of problem seems more indicitive of the error message. 
Comment 11 Andrig Miller 2006-05-19 02:21:33 EDT
The bug referenced by Dominic in the GNOME bugzilla is the issue and it has been
fixed, and will be released as a part of Evolution 2.6.2 on May 31st.

http://bugzilla.gnome.org/show_bug.cgi?id=335561
Comment 12 Brad Laue 2006-05-24 14:55:33 EDT
In the meantime would it be possible to backport the fix? We've been months without Exchange support.
Comment 13 Andrig Miller 2006-05-24 15:20:12 EDT
You need to talk to the Evolution guys through the GNOME project.  I'm just the
original reporter of this problem here.
Comment 14 Andrig Miller 2006-08-21 17:25:54 EDT
This was fixed as of 2.6.2 of Evolution.

Note You need to log in before you can comment on or make changes to this bug.