Bug 186173 - eth0 not created on xen guest
eth0 not created on xen guest
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 18:48 EST by Robin Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 19:06:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2006-03-21 18:48:37 EST
Description of problem: 
If I boot a xen guest using kernel-xenU, the virtual eth0 device does not seem 
to be present, therefore networking cannot be used. 
 
Version-Release number of selected component (if applicable): 
kernel-xenU-2.6.15-1.2054_FC5 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Boot fedora kernel-xenU using e.g. a rpath linux virtual machine image. 
2. "/etc/init.d/network start" in the guest 
   
Actual results: 
Bringing up loopback interface:  Ä  OK  Ü 
Bringing up interface eth0:  Device eth0 does not seem to be present, delaying 
initialization. 
ÄFAILEDÜ 
 
Expected results: 
Should bring up eth0 
 
Additional info: 
I am configured for NAT for the virtual network, not bridge. 
 
The stock kernel from Xen 3.0.1 for x86_64 from XenSource, is able to bring up 
the network, running on the Fedora release of Xen. With the stock kernel, a 
message about bringing up the frontend appears in the syslog; with the fedora 
kernel, no such message appears. 
 
Only lo exists in /proc/net/dev on the guest. 
 
The vif appears to be created correctly on the host, judging by the contents 
of /var/log/xend.log: 
 
[2006-03-21 23:34:23 xend.XendDomainInfo] DEBUG (XendDomainInfo:177) 
XendDomainInfo.create(['vm', ['name', 'rpath2'], ['memory', '600'], 
['on_poweroff', 'destroy'], ['on_reboot', 'restart'], ['on_crash', 'destroy'], 
['vcpus', '1'], ['image', ['linux', ['kernel', 
'/boot/vmlinuz-2.6.15-1.2054_FC5xenU'], ['ramdisk', 
'/boot/initrd-2.6.15-1.2054_FC5xenU.img'], ['root', '/dev/hda2 ro'], ['args', 
'1']]], ['device', ['vbd', ['uname', 'file:/r/qemu/rpath/rpath2.raw'], ['dev', 
'hda'], ['mode', 'w']]], ['device', ['vbd', ['uname', 
'file:/r/qemu/rpath/temp.raw'], ['dev', 'hdb'], ['mode', 'w']]], ['device', 
['vif']]]) 
[2006-03-21 23:34:23 xend.XendDomainInfo] DEBUG (XendDomainInfo:283) 
parseConfig: config is ['vm', ['name', 'rpath2'], ['memory', '600'], 
['on_poweroff', 'destroy'], ['on_reboot', 'restart'], ['on_crash', 'destroy'], 
['vcpus', '1'], ['image', ['linux', ['kernel', 
'/boot/vmlinuz-2.6.15-1.2054_FC5xenU'], ['ramdisk', 
'/boot/initrd-2.6.15-1.2054_FC5xenU.img'], ['root', '/dev/hda2 ro'], ['args', 
'1']]], ['device', ['vbd', ['uname', 'file:/r/qemu/rpath/rpath2.raw'], ['dev', 
'hda'], ['mode', 'w']]], ['device', ['vbd', ['uname', 
'file:/r/qemu/rpath/temp.raw'], ['dev', 'hdb'], ['mode', 'w']]], ['device', 
['vif']]] 
[2006-03-21 23:34:23 xend.XendDomainInfo] DEBUG (XendDomainInfo:379) 
parseConfig: result is {'ssidref': None, 'uuid': None, 'on_crash': 'destroy', 
'on_reboot': 'restart', 'image': ['linux', ['kernel', 
'/boot/vmlinuz-2.6.15-1.2054_FC5xenU'], ['ramdisk', 
'/boot/initrd-2.6.15-1.2054_FC5xenU.img'], ['root', '/dev/hda2 ro'], ['args', 
'1']], 'on_poweroff': 'destroy', 'cpus': None, 'name': 'rpath2', 'backend': 
[], 'vcpus': 1, 'cpu_weight': None, 'vcpu_avail': None, 'memory': 600, 
'device': [('vbd', ['vbd', ['uname', 'file:/r/qemu/rpath/rpath2.raw'], ['dev', 
'hda'], ['mode', 'w']]), ('vbd', ['vbd', ['uname', 
'file:/r/qemu/rpath/temp.raw'], ['dev', 'hdb'], ['mode', 'w']]), ('vif', 
['vif'])], 'bootloader': None, 'cpu': None, 'maxmem': None} 
[2006-03-21 23:34:23 xend.XendDomainInfo] DEBUG (XendDomainInfo:1142) 
XendDomainInfo.construct: None 0 
[2006-03-21 23:34:23 xend.XendDomainInfo] DEBUG (XendDomainInfo:1174) 
XendDomainInfo.initDomain: 2 1.0 
[2006-03-21 23:34:23 xend] DEBUG (balloon:84) Balloon: free 601; need 601; 
done. 
[2006-03-21 23:34:23 xend] INFO (image:135) buildDomain os=linux dom=2 vcpus=1 
[2006-03-21 23:34:23 xend] DEBUG (image:173) dom            = 2 
[2006-03-21 23:34:23 xend] DEBUG (image:174) image          
= /boot/vmlinuz-2.6.15-1.2054_FC5xenU 
[2006-03-21 23:34:23 xend] DEBUG (image:175) store_evtchn   = 1 
[2006-03-21 23:34:23 xend] DEBUG (image:176) console_evtchn = 2 
[2006-03-21 23:34:23 xend] DEBUG (image:177) cmdline        =  root=/dev/hda2 
ro 1 
[2006-03-21 23:34:23 xend] DEBUG (image:178) ramdisk        
= /boot/initrd-2.6.15-1.2054_FC5xenU.img 
[2006-03-21 23:34:23 xend] DEBUG (image:179) vcpus          = 1 
[2006-03-21 23:34:23 xend] DEBUG (image:180) features       = 
[2006-03-21 23:34:23 xend] DEBUG (DevController:103) DevController: writing 
{'virtual-device': '768', 'backend-id': '0', 'state': '1', 'backend': 
'/local/domain/0/backend/vbd/2/768'} to /local/domain/2/device/vbd/768. 
[2006-03-21 23:34:23 xend] DEBUG (DevController:105) DevController: writing 
{'domain': 'rpath2', 'frontend': '/local/domain/2/device/vbd/768', 'dev': 
'hda', 
'state': '1', 'params': '/r/qemu/rpath/rpath2.raw', 'mode': 'w', 
'frontend-id': '2', 'type': 'file'} to /local/domain/0/backend/vbd/2/768. 
[2006-03-21 23:34:23 xend] DEBUG (blkif:24) exception looking up device number 
for hdb: [Errno 2] No such file or directory: '/dev/hdb' 
[2006-03-21 23:34:23 xend] DEBUG (DevController:103) DevController: writing 
{'virtual-device': '832', 'backend-id': '0', 'state': '1', 'backend': 
'/local/domain/0/backend/vbd/2/832'} to /local/domain/2/device/vbd/832. 
[2006-03-21 23:34:23 xend] DEBUG (DevController:105) DevController: writing 
{'domain': 'rpath2', 'frontend': '/local/domain/2/device/vbd/832', 'dev': 
'hdb', 
'state': '1', 'params': '/r/qemu/rpath/temp.raw', 'mode': 'w', 'frontend-id': 
'2', 'type': 'file'} to /local/domain/0/backend/vbd/2/832. 
[2006-03-21 23:34:23 xend] DEBUG (DevController:103) DevController: writing 
{'backend-id': '0', 'mac': '00:16:3e:78:8c:f6', 'handle': '0', 'state': '1', 
'backend': '/local/domain/0/backend/vif/2/0'} to /local/domain/2/device/vif/0. 
[2006-03-21 23:34:23 xend] DEBUG (DevController:105) DevController: writing 
{'mac': '00:16:3e:78:8c:f6', 'state': '1', 'handle': '0', 'script': 
'/etc/xen/scripts/vif-nat dhcp=yes', 'frontend-id': '2', 'domain': 'rpath2', 
'frontend': '/local/domain/2/device/vif/0'} 
to /local/domain/0/backend/vif/2/0. 
[2006-03-21 23:34:23 xend.XendDomainInfo] DEBUG (XendDomainInfo:667) Storing 
VM details: {'ssidref': '0', 'uuid': '0b27b1fb-ee51-b04b-5307-a2613748bc30', 
'on_reboot': 'restart', 'start_time': '1142984063.75', 'on_poweroff': 
'destroy', 'name': 'rpath2', 'vcpus': '1', 'vcpu_avail': '1', 'memory': '600', 
'on_crash': 'destroy', 'image': "(linux 
(kernel /boot/vmlinuz-2.6.15-1.2054_FC5xenU) 
(ramdisk /boot/initrd-2.6.15-1.2054_FC5xenU.img) (root '/dev/hda2 ro') (args 
1))", 
'maxmem': '600'} 
[2006-03-21 23:34:23 xend.XendDomainInfo] DEBUG (XendDomainInfo:692) Storing 
domain details: {'console/ring-ref': '72974', 'console/port': '2', 'name': 
'rpath2', 'console/limit': '1048576', 'vm': 
'/vm/0b27b1fb-ee51-b04b-5307-a2613748bc30', 'domid': '2', 
'cpu/0/availability': 'online', 'memory/target': '614400', 'store/ring-ref': 
'73072', 'store/port': '1'} 
[2006-03-21 23:34:23 xend] DEBUG (DevController:132) Waiting for devices vif. 
[2006-03-21 23:34:23 xend] DEBUG (DevController:138) Waiting for 0. 
[2006-03-21 23:34:23 xend] DEBUG (DevController:403) 
hotplugStatusCallback /local/domain/0/backend/vif/2/0/hotplug-status. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:403) 
hotplugStatusCallback /local/domain/0/backend/vif/2/0/hotplug-status. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:417) hotplugStatusCallback 1. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:132) Waiting for devices usb. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:132) Waiting for devices vbd. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:138) Waiting for 768. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:403) 
hotplugStatusCallback /local/domain/0/backend/vbd/2/768/hotplug-status. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:417) hotplugStatusCallback 1. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:138) Waiting for 832. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:403) 
hotplugStatusCallback /local/domain/0/backend/vbd/2/832/hotplug-status. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:417) hotplugStatusCallback 1. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:132) Waiting for devices pci. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:132) Waiting for devices 
ioports. 
[2006-03-21 23:34:24 xend] DEBUG (DevController:132) Waiting for devices vtpm. 
[2006-03-21 23:34:24 xend] INFO (XendDomain:360) Domain rpath2 (2) unpaused.
Comment 1 Robin Green 2006-03-21 18:57:33 EST
See also https://www.redhat.com/archives/fedora-xen/2006-March/msg00057.html 
which might be the same problem. 
 
Coincidentally(?) I am also using a tg3 driver on dom0. 
Comment 2 Robin Green 2006-03-21 19:06:04 EST
Oops! Not a bug. I just had to do modprobe xennet. I'll note this on the wiki. 

Note You need to log in before you can comment on or make changes to this bug.