Bug 186175 - Some Eclipse updates are broken
Some Eclipse updates are broken
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
Depends On:
  Show dependency treegraph
Reported: 2006-03-21 19:11 EST by Jon Smirl
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-05 16:01:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jon Smirl 2006-03-21 19:11:51 EST
Eclipse updates worked fine for me on FC4, now I am having all kinds of trouble
with them. No matter what I do I cannot get Web Tools to install.


I get various errors, Null pointer, cast exceptions, internal errors, etc...

This is from a clean FC5 install. No .eclipse or workspace from FC4.
Comment 1 Jon Smirl 2006-03-21 20:30:47 EST
Here's the cast error:

org.eclipse.update.internal.core.SiteFilePackedPluginContentConsumer cannot be
cast to org.eclipse.update.internal.core.SiteFilePluginContentConsumer

I am slowly getting things installed by restarting Eclipse after each update.
Doing everything in a group fails.
Comment 2 Ben Konrath 2007-02-06 14:00:26 EST
We fixed a bunch of issues with the way the update manager works with FC-6, have
you tried the packages from FC-6 yet?

Note You need to log in before you can comment on or make changes to this bug.