Bug 186179 - Start search & indexing services automatically checkbox does nothing
Start search & indexing services automatically checkbox does nothing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 186837 193553 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 19:20 EST by Austin Jackson
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 07:20:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Austin Jackson 2006-03-21 19:20:12 EST
Description of problem:
System -> Preferences -> Search & Indexing preferences do nothing.

Version-Release number of selected component (if applicable):
beagle - 0.2.3-4.i386
libbeagle - 0.2.3-4.i386
libbeagle-python - 0.2.3-4.i386

How reproducible:
every time

Steps to Reproduce:
1.check box "Start search & indexing services automatically."
2.re-login
3.check for running beagled process
  
Actual results:
The beagled process does not exist

Expected results:
The beagled process should be running

Additional info:
it seems the hotkey preference does not work either.
Comment 1 Florin Andrei 2006-03-22 13:04:59 EST
I confirm everything in the original bug report.

What I did as a workaround: I went to System / Preferences / More Preferences /
Sessions / Startup Programs and added beagled to the list of programs
automatically launched. Then beagled does run after logging in. However, this
does not seem to be a nice solution.
Comment 2 Aaron VanDevender 2006-03-22 19:16:24 EST
It would be a better design if the hotkey preference were moved to the gnome key
shortcuts dialog, since that's where those things are supposed to go. That would
allow for other shortcuts besides just [Ctl] [Alt] <F[1-12]> as options. It
would also be nice if the keyboard shortcut actually worked.
Comment 3 J.B. Nicholson-Owens 2006-03-25 17:16:48 EST
I can confirm everything here too:

- the beagled process doesn't run on login by default (and adding it to the
startup programs prefs is not something beginners will think to do).

- beagled doesn't run when you first issue a search (and I'd also add that this
is suboptimal because this means what you're looking for might not have been
indexed yet, so you have to wait for the new stuff instead of finding it right
away).

- the hotkey doesn't work.  Nothing is brought up when I hit the search hotkey.

I'd also add:

- the preference dialog is too narrow when you make your default application
text a little larger.  So the hotkey setting becomes invisible because it's not
"in" the window as far as what the user can see.

- it's weird (in a bad way) that the search panel one can add to their panel is
the old brute-force search but the search in the Places menu is the Beagle
search.  I'd say pick one and go with it; if there are no legal problems with
the Beagle (and I'm assuming there aren't, or else Fedora Core would never have
included it in the first place), pick the Beagle search.
Comment 4 Rahul Sundaram 2006-03-26 19:41:07 EST
*** Bug 186837 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Larsson 2006-03-27 03:29:29 EST
The beagle auto-start was disabled in 0.2.2-3:
* Wed Mar  8 2006 Ray Strode <rstrode@redhat.com> - 0.2.2-3
- turn off beagle by default to limit the severity of
  bug 183898

Maybe this is related to why the checkbox doesn't work.
Comment 6 Alexander Larsson 2006-06-21 05:48:34 EDT
*** Bug 193553 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Larsson 2006-08-14 07:20:15 EDT
This is fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.