Bug 186180 - Diminished font quality with this version of ghostscript
Diminished font quality with this version of ghostscript
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 19:28 EST by Gérard Milmeister
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 07:38:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of evince (78.66 KB, image/png)
2006-12-15 11:36 EST, Gérard Milmeister
no flags Details
Screenshot of evince/rawhide displaying guide.ps (87.20 KB, image/png)
2006-12-15 19:06 EST, Saikat Guha
no flags Details
Screenshot of evince display guide.ps on FC4 (80.37 KB, image/png)
2006-12-18 12:11 EST, Gérard Milmeister
no flags Details

  None (edit)
Description Gérard Milmeister 2006-03-21 19:28:42 EST
Font rendering is noticeably worse in 8.15 compared to the
version in FC4. This problem has been reported in:

http://www.ghostscript.com/pipermail/bug-gs/2004-April/003412.html

and

http://bugs.ghostscript.com/show_bug.cgi?id=687419

Maybe one should investigate, if one apply a patch to restore
the previous font rendering.

Since this affects evince as well as ImageMagick, this can
have a wide impact on the rendering of graphics with fonts.
For example I use convert to generate .png from .eps files.
Comment 1 Saikat Guha 2006-04-06 10:30:18 EDT
Confirming this bug.

Downgrading ghostscript in FC5 to version 7.07-40 from FC4 is a temporary fix
the problem. Downgrade requires getting rid of gimp though.
Comment 2 Gérard Milmeister 2006-04-06 10:45:53 EDT
With ghostscript 8.53, rendering is better, but still as good as
ghostscript 7.07. However 8.53 is not GPL. I wonder if there is
an easy fix for this.
BTW, it seems that this affects mainly the x11 backend.
Comment 3 Tim Waugh 2006-12-15 07:04:43 EST
Does this problem still occur?  If so, please provide a test case.
Comment 4 Saikat Guha 2006-12-15 07:21:01 EST
Rendering seems fine on rawhide.

gv-3.6.2-2.fc7
ghostscript-8.15.3-2.fc7
fontconfig-2.4.1-3.fc6
freetype-2.2.1-15.fc6
Comment 5 Gérard Milmeister 2006-12-15 11:36:18 EST
Created attachment 143782 [details]
Screenshot of evince

This screenshot shows evince displaying the file
/usr/share/texmf/doc/latex/general/guide.ps
from the tetex package. The text rendering is very bad.
Comment 6 Saikat Guha 2006-12-15 19:06:02 EST
Created attachment 143835 [details]
Screenshot of evince/rawhide displaying guide.ps
Comment 7 Tim Waugh 2006-12-18 10:47:16 EST
What does 'rpm -q ghostscript' say, corresponding to the FC6 screenshot?
Comment 8 Gérard Milmeister 2006-12-18 12:09:55 EST
ghostscript-8.15.3-1.fc6
Comment 9 Gérard Milmeister 2006-12-18 12:11:37 EST
Created attachment 143914 [details]
Screenshot of evince display guide.ps on FC4

For comparison, here is the rendering on FC4.

Note You need to log in before you can comment on or make changes to this bug.