Bug 186196 - Start of week for clock applet
Start of week for clock applet
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 187097 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 00:15 EST by Jon Smirl
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 17:32:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Smirl 2006-03-22 00:15:58 EST
In the clock-applet the start of the week always is always Monday. Is there a UI
for changing this? I know the GTK widget allows Sunday.

Why is this defaulting to start on Monday in the US locale? Every calendar I own
starts the week on Sunday.

This applet has done it this way forever in Redhat.
Comment 1 Kaj J. Niemi 2006-03-22 06:28:25 EST
There are places on the planet where the week starts on Saturday (for example
Asia/Riyadh should be one) so having it configurable for any weekday would be
the best... ;-)

Comment 2 Jon Smirl 2006-03-22 10:09:34 EST
The applet should pick up the start of the week from the locale of the machine. 

Start of the week is a field in the locale info. 12hr vs 24hr clock is also in
the locale info. There shouldn't be a specific UI in the clock applet for
setting this.
Comment 3 Tom Georgoulias 2006-03-27 08:36:47 EST
Starting the week on Monday seems to be new in FC5.  Not sure what the best way
to accomplish this would be, but Evolution lets you select the first day of the
week, so human configurable is not making radical changes.  I'd prefer the
option of letting the user change the preference from the calendar applet
myself, but the most important thing would just be the ability to change it
somewhere.  I've been getting dates mmixed ever since I upgraded to FC5...
Comment 4 Alex Kloss 2006-05-17 18:43:58 EDT
*** Bug 187097 has been marked as a duplicate of this bug. ***
Comment 5 Ray Strode [halfline] 2007-08-15 17:32:31 EDT
It seems to start on Sunday for me.  Since this bug is rather old now, i'm going
to close it WORKSFORME.   It's probably been fixed by upstream since you've seen
the problem. If I'm wrong, and you're still seeing this problem, please reopen
the report and we can investigate.

Note You need to log in before you can comment on or make changes to this bug.