Bug 186212 - font rendering is strange in xorg-x11-server snapshot.
font rendering is strange in xorg-x11-server snapshot.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 186486 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 04:47 EST by sangu
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 11:49:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot in xorg-x11-server snapshot (1.17 MB, image/png)
2006-03-22 04:47 EST, sangu
no flags Details
xorg log (38.12 KB, text/plain)
2006-03-22 04:51 EST, sangu
no flags Details
xorg.conf (7.14 KB, text/plain)
2006-03-22 04:52 EST, sangu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 6349 None None None Never

  None (edit)
Description sangu 2006-03-22 04:47:20 EST
Description of problem:
characters disappear on applications.

Version-Release number of selected component (if applicable):
1.0.99.1-1

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
nvidia closed driver 1.0.8178
Comment 1 sangu 2006-03-22 04:47:21 EST
Created attachment 126458 [details]
screenshot in xorg-x11-server snapshot
Comment 2 sangu 2006-03-22 04:51:03 EST
Created attachment 126459 [details]
xorg log
Comment 3 sangu 2006-03-22 04:52:01 EST
Created attachment 126460 [details]
xorg.conf
Comment 4 sangu 2006-03-22 06:11:47 EST
This bug seems nvidia closed driver bug.

So report to this : https://bugs.freedesktop.org/show_bug.cgi?id=6349

Comment 5 Sammy 2006-03-22 11:36:31 EST
Perhaps, but this is not FC5. Closed driver is working fine on FC5, which
is based on 1.0.9. This happens if you update to FC6-devel from rawhide.
Comment 6 Mike A. Harris 2006-03-22 11:49:30 EST
Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "CANTFIX" (unsupported).
Comment 7 Valdis Kletnieks 2006-03-22 22:52:20 EST
Even if it *is* an NVidia bug, something changed between
xorg-x11-server-Xorg-1.0.1-9.i386.rpm (which worked fine) and
xorg-x11-server-Xorg-1.0.99.1-1.i386.rpm (which demonstrates the problem).

I'll see if I can replicate it with the 'nv' driver.
Comment 8 Valdis Kletnieks 2006-03-23 03:30:49 EST
Confirmed NVidia issue.  Running 1.0.1-9, both 'nv' and 'nvidia' drivers work. 
However, upgrading to 1.0.99-1 results in:

(II) LoadModule: "nv"
(II) Loading /usr/lib/xorg/modules/drivers/nv_drv.so
(II) Module nv: vendor="X.Org Foundation"
       compiled for 7.0.0, module version = 1.0.1
       Module class: X.Org Video Driver
       ABI class: X.Org Video Driver, version 0.8
(this driver works fine, although slow)

(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
       compiled for 4.0.2, module version = 1.0.8178
       Module class: XFree86 Video Driver
(this one craps out with the symptoms described).

I'm guessing some API change between 1.0.1 and 1.0.99 that NVidia needs to
account for....
Comment 9 Bart Vanbrabant 2006-03-23 15:13:14 EST
*** Bug 186486 has been marked as a duplicate of this bug. ***
Comment 10 sangu 2006-03-23 22:31:11 EST
this bug reports to : http://www.nvnews.net/vbulletin/showthread.php?t=66968
Comment 11 Lars G 2006-04-08 21:52:50 EDT
setting font antialiasing in gnome to subpixel smoothing fixed this for me.
another fix is to set "RenderAccel" to "false" in xorg.conf.
Comment 12 sangu 2006-04-09 01:24:16 EDT
From Lars G :  
Using your solution in comment #11 , this problem doesn't be fixed. 

Comment 13 Valdis Kletnieks 2006-04-10 16:28:37 EDT
Following up with info from other bugzillas and similar....

NVidia has ack'ed that it's a driver problem on their part when used under the
most recent Xorg snapshots.  There was an ABI change for the Glyphs code. They
intend to fix this in a future driver release.  It's *not* fixed in the
just-released 8756 drivers.
Comment 14 Mike A. Harris 2006-04-20 13:33:27 EDT
(In reply to comment #7)
> Even if it *is* an NVidia bug, something changed between
> xorg-x11-server-Xorg-1.0.1-9.i386.rpm (which worked fine) and
> xorg-x11-server-Xorg-1.0.99.1-1.i386.rpm (which demonstrates the problem).

Hopefully that information will be useful to Nvidia when they diagnose
the problem in their driver.


Note You need to log in before you can comment on or make changes to this bug.