Bug 186228 - undefined symbol in kdeprint_cups.so
undefined symbol in kdeprint_cups.so
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Depends On:
  Show dependency treegraph
Reported: 2006-03-22 08:09 EST by Neal Becker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-30 05:48:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2006-03-22 08:09:56 EST
Description of problem:  
There was an error loading kdeprint_cups. The diagnostic is:  
/usr/lib64/kde3/kdeprint_cups.so: undefined symbol: _ipp_free_attr  
Version-Release number of selected component (if applicable):  
How reproducible:  
Steps to Reproduce:  
Actual results:  
Expected results:  
Additional info:
Comment 1 Linda Worthington 2006-03-23 06:10:33 EST
I am having the same problem. With pre-gold FC5 I had two printers set up and
both worked fine. I updated to FC5 and now when I try to print or try to access
Settings > Print Manager I receive the following error:

/usr/lib64/kde3/kdeprint_cups.so: undefined symbol: _ipp_free_attr

I no longer receive the root login screen when accessing Settings > Print Manger
now, just the above error.

This error ocurred after the cups update a few days ago. I opened a terminal,
system-config-printer, and no printers show as installed now. I worked through
the little wizard and "installed" my printer and received the following error
when trying to print:

there was a problem sending cups test page to hp8450 queue: /usr/bin/lpr: the
printer or class was not found

Yet the printer showed as being installed until after the error then the gui
showed no printers installed again.
Comment 2 Neal Becker 2006-03-23 06:44:42 EST
I downgraded to FC5 cups and now there is no problem.  I didn't realize I had 
picked up the devel version of cups. 
Comment 3 Linda Worthington 2006-03-23 09:25:12 EST
(In reply to comment #2)
> I downgraded to FC5 cups and now there is no problem.  I didn't realize I had 
> picked up the devel version of cups. 

I downgraded to FC5 just now and printing is back to normal. Thanks for the
Comment 4 Ngo Than 2006-03-30 05:48:55 EST
I cannot reproduce this problem with fresh installed FC5. It works fine for me
here. it looks like you have installed cups version from rawhide.

Note You need to log in before you can comment on or make changes to this bug.