Bug 186239 - Powerbook G4 locks up when starting X server.
Powerbook G4 locks up when starting X server.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 09:41 EST by Alex Karasulu
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 20:13:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the xorg.conf file (3.02 KB, text/plain)
2006-03-22 09:41 EST, Alex Karasulu
no flags Details
the xorg log file generated for attached xorg.conf (33.20 KB, text/plain)
2006-03-22 09:50 EST, Alex Karasulu
no flags Details
Working config. Comment out the line --Load "dri"-- to freeze the system. (2.91 KB, text/plain)
2006-03-25 07:31 EST, Frank Arnold
no flags Details
Log with a working config (134.42 KB, text/plain)
2006-03-25 07:34 EST, Frank Arnold
no flags Details
Log with dri disabled (33.42 KB, text/plain)
2006-03-25 07:36 EST, Frank Arnold
no flags Details
system-config-display log (851 bytes, text/plain)
2006-06-06 21:11 EDT, Gavin Scott
no flags Details
Config file referenced by system-config-display log (2.55 KB, application/octet-stream)
2006-06-06 21:12 EDT, Gavin Scott
no flags Details

  None (edit)
Description Alex Karasulu 2006-03-22 09:41:32 EST
Description of problem:

When I start up the xserver the entire system locks up.  My virtual consoles
freeze and lock up.  I cannot ping the machine any longer.  This is all on an
Apple Powerbook G4 17in model.  The machine basically locks up/ 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alex Karasulu 2006-03-22 09:41:32 EST
Created attachment 126473 [details]
the xorg.conf file
Comment 2 Alex Karasulu 2006-03-22 09:50:52 EST
Created attachment 126476 [details]
the xorg log file generated for attached xorg.conf
Comment 3 Mike A. Harris 2006-03-22 11:45:31 EST
It appears that there are multiple problems happening:

(II) Reloading /usr/lib/xorg/modules/drivers/radeon_drv.so
(WW) ****INVALID IO ALLOCATION**** b: 0xf0000400 e: 0xf00004ff correcting
(EE) end of block range 0xefffffff < begin 0xf0000000

(WW) RADEON(0): Video BIOS not detected in PCI space!
(WW) RADEON(0): Attempting to read Video BIOS from legacy ISA space!
(WW) RADEON(0): Unrecognized BIOS signature, BIOS data will not be used

(WW) RADEON(0): Video BIOS not detected, using default clock settings!
(II) RADEON(0): Probed PLL values: xtal: 27.000000 Mhz, sclk: 391.500000 Mhz,
mclk: 202.500000 Mhz
(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled
(==) RADEON(0): Using gamma correction (1.0, 1.0, 1.0)
(II) RADEON(0): Validating modes on Primary head ---------
(II) RADEON(0): Existing panel PLL dividers will be used.
(WW) RADEON(0): Panel size 1440x900 is derived, this may not be correct.
If not, use PanelSize option to overwrite this setting

(WW) RADEON(0): Enabling DRM support

	*** Direct rendering support is highly experimental for Radeon 9500
	*** and newer cards. The 3d mesa driver is not provided in this tree.
	*** A very experimental (and incomplete) version is available from Mesa CVS.
	*** Additional information can be found on http://r300.sourceforge.net
	*** This message has been last modified on 2005-08-07.

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed


At this point your log file ends, implying that enabling DRI is causing the
machine to hang.  Are you using the Red Hat official kernel for FC5, as
supplied by Red Hat?  We have disabled R300+ DRM support, so the kernel
modules should not even load at all.

Please try commenting out the line:  Load "dri" in the config file, and
rebooting and restarting X again.  Does that allow the server to start?
Comment 4 Alex Karasulu 2006-03-22 12:27:38 EST
I have done that already and it still hangs even with DRI removed.  The server
appears to start since I see some vertical lines on the display in the right
hand side.  However the machine is completly hung still.
Comment 5 Ken Bauer 2006-03-22 18:37:42 EST
Confirming same behaviour on the most recent G4 powerbook 15"

I was also forced to install in text mode (but always had to deal with that in 
my previous life of working on thinkpads).

Comment 6 Alex Karasulu 2006-03-22 20:51:47 EST
I forgot to mention that I too had to install in text mode.  Sorry about
forgetting this important point but I guess you could infer that.
Comment 7 Mike A. Harris 2006-03-23 23:32:13 EST
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 8 Ken Bauer 2006-03-24 01:00:41 EST
This looks like the same bug which was posted 1-21-2006:
https://bugs.freedesktop.org/show_bug.cgi?id=5580

- Ken
Comment 9 Frank Arnold 2006-03-24 11:36:51 EST
I don't think the freedesktop bug is related to this issue. I've followed the
whole development cycle with my PowerBook (PowerBook5,6 - Radeon 9700) and had
no major problems. Even GL worked as long as it was enabled. Todays 'yum update'
broke it.

Up to including xorg-x11-server-1.0.1-8 everything is fine for me.

With 1.0.1-9 I could login once. After logout the screen vanished from solid
light red to grey and Xorg used a lot of CPU. However, I could switch to a VT at
least. This behaviour is known, but occured only when switching to a VT and back
to X.

The current cvs snapshot in devel is totally broken. It doesn't display
anything, although the graphical startup seems to work. Not sure if it's an
ati-drv or server problem.
Comment 10 Frank Arnold 2006-03-25 07:31:50 EST
Created attachment 126709 [details]
Working config. Comment out the line --Load "dri"-- to freeze the system.

Forget about my last comment. I meddled with different configs yesterday and
can't recall what I've done there.

Today I tracked it down further. All package versions seem to behave the same
way. If the module "dri" isn't explicitly loaded, everything hangs.

I'll attach a working xorg.conf (a little bit cluttered, and needs some
modification for 17") as well as good/bad logs from a setup with current devel
packages.

HTH
Comment 11 Frank Arnold 2006-03-25 07:34:20 EST
Created attachment 126710 [details]
Log with a working config
Comment 12 Frank Arnold 2006-03-25 07:36:07 EST
Created attachment 126711 [details]
Log with dri disabled
Comment 13 Gavin Scott 2006-06-06 21:08:35 EDT
This is a me too comment.  I have the last rev 15" powerbook g4 (PowerBook5,8).
 The FC5 gui installer hung.  After doing a "linux text" install and yum update,
running system-config-display hangs the system completely.  I will attach the
log from that.

As a possibly unhelpful data point, Ubuntu Dappy Flight 7 had this problem as
well but the Release Candidate (and final release) do not.
Comment 14 Gavin Scott 2006-06-06 21:11:04 EDT
Created attachment 130650 [details]
system-config-display log
Comment 15 Gavin Scott 2006-06-06 21:12:57 EDT
Created attachment 130651 [details]
Config file referenced by system-config-display log
Comment 16 Gavin Scott 2006-06-08 11:12:37 EDT
FYI upgrading to xorg-x11-server-Xorg-1.1.0-3.ppc.rpm and
xorg-x11-drv-ati-6.6.0-3.ppc.rpm from rawhide resolved the issue for me.
Comment 17 Mike A. Harris 2006-06-08 20:13:53 EDT
Thanks, closing as fixed in "RAWHIDE".

Note You need to log in before you can comment on or make changes to this bug.