Bug 186302 - xchat 2.6.0-4 locks gnome desktop on load
xchat 2.6.0-4 locks gnome desktop on load
Status: CLOSED DUPLICATE of bug 188894
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 14:33 EST by warren
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 08:33:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description warren 2006-03-22 14:33:23 EST
Description of problem: 
on start xchat loads, auto logs into efnet/#channel then proceeds to freeze the
gnome desktop. system is still accessible via ssh

Version-Release number of selected component (if applicable):
xchat-debuginfo-2.6.0-4gnome desktop freezes or xchat segfaults
xchat-2.6.0-4

How reproducible: 
start xchat as user, set to autojoin #foo on any network


Steps to Reproduce:
1. start xchat 2.6.0-4 as user
2. try to click on any window or desktop icon / taskbar
3.
  
Actual results: 
gnome desktop freezes or xchat segfaults

Expected results: 
gnome desktop freezes or xchat segfaults

Additional info:

   1.
      (gdb) run
   2.
      Starting program: /usr/bin/xchat
   3.
      Reading symbols from shared object read from target memory...done.
   4.
      Loaded system supplied DSO at 0x830000
   5.
      [Thread debugging using libthread_db enabled]
   6.
      [New Thread -1208834384 (LWP 13646)]
   7.
      /home/warren/.themes/Tactile/gtk-2.0/gtkrc:1046: Unable to locate image
file in pixmap_path: "spin_button_up_arrow_prelight.png"
   8.
      /home/warren/.themes/Tactile/gtk-2.0/gtkrc:1050: Overlay image options
specified without filename
   9.
      /home/warren/.themes/Tactile/gtk-2.0/gtkrc:1056: Unable to locate image
file in pixmap_path: "spin_button_down_arrow_prelight.png"
  10.
      /home/warren/.themes/Tactile/gtk-2.0/gtkrc:1060: Overlay image options
specified without filename
  11.
       
  12.
      (xchat:13646): GLib-CRITICAL **: g_key_file_add_group: assertion
`g_key_file_lookup_group_node (key_file, group_name) == NULL' failed
  13.
  14.
      (xchat:13646): GLib-CRITICAL **: g_key_file_add_group: assertion
`g_key_file_lookup_group_node (key_file, group_name) == NULL' failed
  15.
       
  16.
      (xchat:13646): GLib-CRITICAL **: g_key_file_add_group: assertion
`g_key_file_lookup_group_node (key_file, group_name) == NULL' failed
  17.
  18.
      (xchat:13646): GLib-CRITICAL **: g_key_file_add_group: assertion
`g_key_file_lookup_group_node (key_file, group_name) == NULL' failed
  19.
       
  20.
      (xchat:13646): GLib-CRITICAL **: g_key_file_add_group: assertion
`g_key_file_lookup_group_node (key_file, group_name) == NULL' failed
  21.
      Detaching after fork from child process 13650.
  22.
  23.
      Program received signal SIGSEGV, Segmentation fault.
  24.
      [Switching to Thread -1208834384 (LWP 13646)]
  25.
      0x00c2aab8 in strcmp () from /lib/libc.so.6
  26.
      (gdb) Killed
  27.
      [warren@trango ~]$ 
-------------------------------------------------------------------------
gdb must be remotely killed via ssh. i have tried this on 3 systems so far.
xchat 2.4.3 seems to have no problems whatsoever. this problem is reproducible
by me on fc4 or fc5. fc4 kernel 1831/1833 and fc5 kernel 2054
Comment 1 warren 2006-03-28 12:02:07 EST
this seems to be a theme related issue that only affects xchat 2.6.0 and gnome
users with certain themes. does not happen to all gnome users or users under kde
or xfce. so far 4 people have reported this bug in #fedora on freenode.
Comment 2 Craig Kelley 2006-04-17 09:48:58 EDT
see also bug #188894
Comment 3 Craig Kelley 2006-04-17 10:42:50 EDT
I've changed themes to the default, Crux and others to no avail.
Comment 4 Kevin Kofler 2007-07-10 08:33:06 EDT
Closing as duplicate because #188894 has more information.

*** This bug has been marked as a duplicate of 188894 ***

Note You need to log in before you can comment on or make changes to this bug.