Bug 18632 - Installer crash during upgrade
Installer crash during upgrade
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-08 07:02 EDT by pergj
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-27 15:11:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pergj 2000-10-08 07:02:43 EDT
While upgrading from 6.2 and choosing to select individual packages to
upgrade the 
installer crashes, giving me this traceback:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 412, in
nextClicked
    next = self.currentScreen.getNext ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/examine_gui.py", line
19, in getNext
    self.todo.upgradeFindPackages (self.root)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 919, in
upgradeFindPackages
    if self.fstab.hasDirtyFilesystems():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 675, in
hasDirtyFilesystems
    if self.rootOnLoop():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 160, in
rootOnLoop
    raise ValueError, "no root device has been set"
ValueError: no root device has been set

Local variables in innermost frame:
self: <fstab.GuiFstab instance at 84dfcc0>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-10-09 11:21:55 EDT
Please attach the partition table and /etc/fstab for the 6.2 system you are
upgrading - we will need this information to reproduce the problem you are
seeing.
Comment 2 pergj 2000-10-09 16:29:21 EDT
Sorry for bothering you with this, the fault is probably mine since I have been
running devfs on this machine. I considered changing the bug status to resolved,
but leave it as it is. The error reported 
could have been a bit easier to understand. The fstab and partition information
is included below.

/dev/ide/host0/bus0/target0/lun0/part2               /                      
ext2    defaults        1 1
/dev/ide/host0/bus0/target0/lun0/part5               /usr                   
ext2    defaults        1 2
/dev/ide/host0/bus0/target0/lun0/part6               /usr/local             
ext2    defaults        1 2
/dev/ide/host0/bus0/target0/lun0/part3               /var                   
ext2    defaults        1 2
/dev/ide/host0/bus0/target0/lun0/part1               swap                   
swap    defaults        0 0
/dev/fd0		/mnt/floppy	ext2	 user,exec,dev,nosuid,rw,noauto 0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,ro       0 0
/dev/ide/host0/bus0/target0/lun0/part7               /chrome/a              
ext2    defaults        1 2
/dev/ide/host0/bus0/target0/lun0/part8		/chrome/mp3		ext2	defaults	1 2

Disk /dev/hda: 255 heads, 63 sectors, 1550 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1        16    128488+  82  Linux swap
/dev/hda2            17        56    321300   83  Linux
/dev/hda3            57       120    514080   83  Linux
/dev/hda4           121      1550  11486475    5  Extended
/dev/hda5           121       439   2562336   83  Linux
/dev/hda6           440       758   2562336   83  Linux
/dev/hda7           759      1013   2048256   83  Linux
/dev/hda8          1014      1550   4313421   83  Linux

Comment 3 Michael Fulbright 2000-10-27 15:11:26 EDT
Yeah I think you have uncovered the problem - there is not support for devfs
currently.

If you rewrite your fstab to the classic format for specifying devices you might
have better luck.

Note You need to log in before you can comment on or make changes to this bug.