Bug 186369 - No acceleration on savage driver
No acceleration on savage driver
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-savage (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 03:10 EST by Piotr Wojciechowski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 17:16:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 6390 None None None Never

  None (edit)
Description Piotr Wojciechowski 2006-03-23 03:10:17 EST
Description of problem:

It seems new savage driver support no acceleration :(

I have laptop Compaq Presario 700 with graphic card:
01:00.0 VGA compatible controller: S3 Inc. VT8636A [ProSavage KN133] AGP4X VGA
Controller (TwisterK) (rev 01)

In xorg its working under savage driver. Problem is that all acceleration is
disabled. Graphics works very slow, can't watch even movie via mplayer because
of slow rendering, while opening picture full screen or starting gdm login
screen you can see how its slowly rendering. It all slowing down system very
much and make it unusable for all multimedia stuff.

There is also problem while resetting X server under this driver, it sometimes
not coming back to text mode

Configuration section

Section "Device"
        Identifier  "Videocard0"
        Driver      "savage"
        BoardName   "S3 ProSavage KN133"
EndSection


How reproducible:

Use savage driver on latest xorg

Steps to Reproduce:
1. Install FC5
2. Install xorg with savage driver
3. Try to use
  
Actual results:

System working slowly and without acceleration, can't use any multimedia
applications

Expected results:

Acceleration like in xorg from FC4

Additional info:
Comment 1 Mike A. Harris 2006-03-25 03:15:27 EST
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 2 Piotr Wojciechowski 2006-03-25 03:46:01 EST
Here is requested URL:

https://bugs.freedesktop.org/show_bug.cgi?id=6390
Comment 3 Mike A. Harris 2006-03-27 17:16:06 EST
Thanks, tracking in X.Org bugzilla now.

Note You need to log in before you can comment on or make changes to this bug.