Bug 186376 - util-vserver 0.30.210 doesn't 'export' function vc_new_s_context
Summary: util-vserver 0.30.210 doesn't 'export' function vc_new_s_context
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: util-vserver (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Enrico Scholz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-23 08:46 UTC by Oliver Falk
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-23 10:16:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oliver Falk 2006-03-23 08:46:29 UTC
Description of problem:
util-vserver 0.30.210 doesn't 'export' vc_new_s_context:

[oliver@zywiec ~]$ strings
/usr/src/redhat/SOURCES/util-vserver-0.30.209/lib/.libs/libvserver.so|grep -i new
vc_new_s_context
[oliver@zywiec ~]$ strings /usr/lib/libvserver.so|grep -i new
[oliver@zywiec ~]$ 

Version-Release number of selected component (if applicable): 0.30.210

0.30.209 doesn't seem to have this problem...

How reproducible: Always, compile 0.30.210.

Steps to Reproduce:
1. as above

Actual results:
Should export this function.

Comment 1 Enrico Scholz 2006-03-23 10:16:12 UTC
vc_new_s_context() is part of the legacy/compat API which is disabled since
0.30.210 by default. It will be missing in the kernel too when
CONFIG_VSERVER_LEGACY is not enabled. Because util-vserver is not in Fedora
Extras before FE5 (which requires at least kernel 2.6.15), I do not see much
sense in activating options which are for use for older 2.4 kernels only.

You should use vc_ctx_create() + vc_ctx_migrate() in your applications.

Comment 2 Oliver Falk 2006-03-23 17:09:32 UTC
Fine, fine. I was just wondering, because >openvps< uses vc_new_s_context and
I'm currently playing around with it...


Note You need to log in before you can comment on or make changes to this bug.