Bug 18639 - [PATCH]: joe will not rebuild on RH6x (man page locations)
Summary: [PATCH]: joe will not rebuild on RH6x (man page locations)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: joe   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-08 13:57 UTC by Pekka Savola
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 13:39:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-10-08 13:57:41 UTC
joe will not rebuild on RH6x and the previous due to man page handling patch.

This modification to the spec file should make it work with new and old:

--- joe.spec    Sun Oct  8 16:52:37 2000
+++ joe.spec~   Sun Oct  8 16:50:57 2000
@@ -68,7 +68,7 @@
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make install TOPDIR=$RPM_BUILD_ROOT
+make install TOPDIR=$RPM_BUILD_ROOT WHEREMAN=$RPM_BUILD_ROOT/%{_mandir}/man1
 cd $RPM_BUILD_ROOT/%{_mandir}/man1
 ln -s joe.1 jmacs.1 
 ln -s joe.1 jpico.1

Comment 1 Trond Eivind Glomsrxd 2000-10-09 13:39:10 UTC
OK, will add.

Comment 2 Trond Eivind Glomsrxd 2000-10-09 13:51:03 UTC
Added. Thanks.


Note You need to log in before you can comment on or make changes to this bug.