Bug 186423 - Xorg crashes
Xorg crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 09:38 EST by Daniel Veillard
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 10:39:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/etc/X11/xorg.conf (4.61 KB, text/plain)
2006-03-23 09:38 EST, Daniel Veillard
no flags Details
full log from the second crash reported (34.53 KB, text/plain)
2006-03-25 11:52 EST, Daniel Veillard
no flags Details
the Xorg log when booted from the non-Xen kernel (33.29 KB, text/plain)
2006-03-28 16:37 EST, Daniel Veillard
no flags Details
Xorg log file (48.70 KB, text/plain)
2006-05-09 08:49 EDT, Chris Croome
no flags Details
Xorg configuration file (2.98 KB, text/plain)
2006-05-09 08:50 EDT, Chris Croome
no flags Details

  None (edit)
Description Daniel Veillard 2006-03-23 09:38:46 EST
Description of problem:
Xorg crashes, session closed erratically

Version-Release number of selected component (if applicable):
FC5 in Xen Domain0
xorg-x11-server-Xorg-1.0.1-9
xen-3.0.1-4
kernel-2.6.15-1.2054_FC5xen0
01:00.0 VGA compatible controller: Matrox Graphics, Inc. G400/G450 (rev 82)
Running in Xinerama mode with 2 screens

How reproducible:
Erratically happened twice since I reinstalled my workstation under FC5,
3 days ago

Steps to Reproduce:
1. work
2.
3.
  
Actual results:
Xorg crashes after a while

Expected results:
Xorg does not crash

Additional info:

--------------------------------------------
bottom of Xorg.0.log.old hints it's a segfault in GCCopy

SetGrabKeysState - disabled
SetGrabKeysState - enabled

   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x87) [0x80b86c7]
1: [0x93d420]
2: /usr/bin/Xorg(CopyGC+0x3f8) [0x8098508]
3: [0x86d85bf]

Fatal server error:
Caught signal 11.  Server aborting

(II) Screen 0 shares mem & io resources
(II) Screen 1 shares mem & io resources
----------------------------------------

xorg.conf attached
Comment 1 Daniel Veillard 2006-03-23 09:38:46 EST
Created attachment 126547 [details]
/etc/X11/xorg.conf
Comment 2 Daniel Veillard 2006-03-23 09:43:00 EST
Using the following driver I guess:
  xorg-x11-drv-mga-1.2.1.3-1.2

Daniel
Comment 3 Daniel Veillard 2006-03-24 03:20:58 EST
Crashed again after less than 6 hours of work. I actually reading a web page 
at that point, no mouse or keyboard involved at that precise point in time.
Different backtrace:

SetGrabKeysState - disabled
SetGrabKeysState - enabled

   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x87) [0x80b86c7]
1: [0x764420]
2: /usr/bin/Xorg(AllocatePixmap+0x22) [0x8070682]
3: /usr/lib/xorg/modules/libfb.so(fbCreatePixmapBpp+0x82) [0xdbc682]
4: /usr/lib/xorg/modules/libfb.so(fbCreatePixmap+0x52) [0xdbc772]
5: /usr/lib/xorg/modules/libxaa.so [0x36bbf7]
6: /usr/bin/Xorg(ProcCreatePixmap+0x126) [0x8083556]
7: /usr/bin/Xorg(PanoramiXCreatePixmap+0x146) [0x8135676]
8: /usr/bin/Xorg(Dispatch+0x19b) [0x80888eb]
9: /usr/bin/Xorg(main+0x487) [0x80701d7]
10: /lib/i686/nosegneg/libc.so.6(__libc_start_main+0xdc) [0x1167e4]
11: /usr/bin/Xorg(FontFileCompleteXLFD+0xb1) [0x806f511]

Fatal server error:
Caught signal 4.  Server aborting

(II) Screen 0 shares mem & io resources
(II) Screen 1 shares mem & io resources
Comment 4 Daniel Veillard 2006-03-24 03:24:29 EST
The xorg.conf used is the exact same one as what I used previously on RHEL4 and
which never ever crashed...

Daniel
Comment 5 Mike A. Harris 2006-03-24 20:33:22 EST
Please attach the full X server log as an attachment.  Also, please try booting
with the non-Xen kernel and reproducing.  As I mentioned in IRC last night,
there are known issues with X running on top of Xen, of which some appear
to be kernel bugs so far.  It'd be nice to rule Xen out of the equation first
if possible.

Thanks in advance.
Comment 6 Daniel Veillard 2006-03-25 11:52:46 EST
Created attachment 126734 [details]
full log from the second crash reported
Comment 7 Daniel Veillard 2006-03-25 12:26:09 EST
Well X didn't crashed again yet, I will reboot on non-Xen when this happens,
note that don't have a guest system running ATM, while this was the case when 
X crashed previously... this seems to hint at a Xen interraction.

Daniel
Comment 8 Daniel Veillard 2006-03-28 16:35:00 EST
Okay Xen crashed again after 5 days when running on Xen in Domain 0 but while
avoiding any other DomU domain. The bug still exist, but just way harder to
trigger apparently. I now rebooted the same kernel version but without Xen
I will report if it breaks without Xen or not within a week. Attached is
the Xorg log when booted from the non-Xen kernel.

Daniel
Comment 9 Daniel Veillard 2006-03-28 16:37:43 EST
Created attachment 126937 [details]
the Xorg log when booted from the non-Xen kernel
Comment 10 Daniel Veillard 2006-04-05 18:10:45 EDT
Okay I have been running for 6 days now with the normal non Xen kernel
and didn't got any trouble. So I believe the Xorg crash is really related to
Xen :-\

Daniel
Comment 11 Demetri Mouratis 2006-04-26 18:42:35 EDT
I'm running into an X related crash at boot time with my Dom0.  I saw a
workaround relating to FC4 and libint10.a.  The thing is, for FC5 this library
is now a .so /usr/lib/xorg/modules/libint10.so and the workaround of simply
moving it to the side no longer works.  X failed to launch when I moved that
file aside.

Chaning /etc/inittab to default to runlevel 3 is a partial workaround but now I
have no X.  Changing to runlevel 5 via the normal methods causes a hard crash.

See 140847 for more info on the FC4 workaround.  I'd be happy enough if someone
could provide an FC5 workaround to disable the X probing.

# lspci | grep -i vga
06:05.0 VGA compatible controller: XGI - Xabre Graphics Inc Volari Z7

Thanks.
Comment 12 Chris Croome 2006-05-09 08:46:46 EDT
I'm getting Xorg crashing several times a day on FC5 with a Xen0 kernel also,
this is the last timg in the log:

  Fatal server error:
  Caught signal 11.  Server aborting

I'll attach the whole log and the config file.
Comment 13 Chris Croome 2006-05-09 08:49:07 EDT
Created attachment 128780 [details]
Xorg log file
Comment 14 Chris Croome 2006-05-09 08:50:46 EDT
Created attachment 128781 [details]
Xorg configuration file
Comment 15 Chris Croome 2006-05-09 09:07:54 EDT
Oh, I forgot to mention, I'm running with these packages:

  xorg-x11-server-Xorg-1.0.1-9.fc5
  xorg-x11-drv-nv-1.0.1.5-3.1
  kernel-xen0-2.6.16-1.2096_FC5
  xen-3.0.1-4

And selinux=0 in /etc/grub.conf
Comment 16 Mike A. Harris 2006-06-06 00:06:23 EDT
Please report separate bugs if you are experience problems under Xen, even
if it appears they are the exact same problem as Daniel has reported here.
This allows us to track each issue individually, without each bug being
cluttered by information which may or may not be part of the the same issue.
Later on if we determine they are the same issue, we can always close them
as duplicates of each other.

Thanks.
Comment 17 Daniel Veillard 2006-11-02 10:39:32 EST
I don't see the problem anymore with FC6 or rawhide,

Daniel

Note You need to log in before you can comment on or make changes to this bug.