Bug 186426 - Tar multivolume backup crash on x86_64
Tar multivolume backup crash on x86_64
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tar (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 09:57 EST by Michele De Candia Jr
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 09:12:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch extracted from upstream CVS (1.21 KB, patch)
2006-03-30 08:21 EST, Peter Vrabec
no flags Details | Diff

  None (edit)
Description Michele De Candia Jr 2006-03-23 09:57:17 EST
Description of problem:
Retrieving files from a tar multivolume backup (on files or tapes) doesn't
recognize volumes after first one returning error " tar: <filename>  is not
continued on this volume."  

Version-Release number of selected component (if applicable):

tar-1.14.9-1.RHEL4
kernel-2.6.9-22.0.1.ELsmp


Steps to Reproduce:
1.create multivolume archive on tape : tar -M -L <dim> -cvf <device>
<directory_to_backup>
2.read multivolume backup starting from first tape : tar Mxvf <device>
  
Actual results:
On second tape tar doesn't recognize second tape : 
" tar: <filename>  is not continued on this volume."

Expected results:
Tar must continue retrieving files from second tape

Additional info:
Tested on RHEL 4 x86 version and it works correctly.
Comment 1 Peter Vrabec 2006-03-29 07:21:20 EST
I have problem to reproduce it.

$ tar -c -M --tape-length=10240 --file=disk1.tar foo
Prepare volume #2 for `disk1.tar' and hit return: n disk2.tar
Prepare volume #2 for `disk2.tar' and hit return:
Prepare volume #3 for `disk2.tar' and hit return: n disk3.tar
Prepare volume #3 for `disk3.tar' and hit return:
$ tar -x -M --file=disk1.tar
Prepare volume #2 for `disk1.tar' and hit return: n disk2.tar
Prepare volume #2 for `disk2.tar' and hit return:
Prepare volume #3 for `disk2.tar' and hit return: n disk3.tar
Prepare volume #3 for `disk3.tar' and hit return:
$ uname -m
x86_64
$ rpm -q tar
tar-1.14-9.RHEL4
Comment 2 Michele De Candia Jr 2006-03-30 03:38:01 EST
I think the problem is the path length of file on two tapes. Searching on gnu
tar i found that path name on multivolume tar may not be longer than 100 chars.
(http://cvs.savannah.gnu.org/viewcvs/tar/tar/NEWS?rev=1.95&content-type=text/vnd.viewcvs-markup)

Infact, only if I try to make multivolume tar on files longer than 100 chars I
have problems.

Comment 3 Peter Vrabec 2006-03-30 08:21:36 EST
Created attachment 127052 [details]
patch extracted from upstream CVS

Could you reproduce the problem with this tar:
http://people.redhat.com/pvrabec/rpms/tar-1.14-10.RHEL4.src.rpm
Comment 4 Michele De Candia Jr 2006-04-04 03:55:18 EDT
I think this patch doesn't resolve the bug. It stops backup when last file name
is over than 124 characters. 

Thanks anyway.





Comment 5 Peter Vrabec 2006-04-05 06:56:27 EDT
I'm confused. What was your problem? Could u reproduce the bug with tar-1.14.10 from 
comment #3? 
Comment 6 Michele De Candia Jr 2006-04-06 09:35:58 EDT
Yes, I've reproduced the bug with tar-1.14.10. 
My problem was that I need backup on more tapes and I don't want that it stops
at the end of a tape. 
I will use tar-1.14.9 because it continues backup (I'll backup again files
between two tapes).

Note You need to log in before you can comment on or make changes to this bug.