Bug 186454 - autofs never umounts /net/host/dir
autofs never umounts /net/host/dir
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 12:49 EST by H.J. Lu
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 22:36:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/debug (39.66 KB, text/plain)
2006-04-18 11:58 EDT, H.J. Lu
no flags Details
/var/log/debug (39.66 KB, text/plain)
2006-04-18 12:01 EDT, H.J. Lu
no flags Details
Patch which removes the problem (694 bytes, patch)
2006-04-24 14:02 EDT, Ahmon Dancy
no flags Details | Diff

  None (edit)
Description H.J. Lu 2006-03-23 12:49:12 EST
With autofs-4.1.4-16.2.2, autofs never umounts /net/host/dir after I did

# cd /net/host/dir
# ls
# cd /
Comment 1 H.J. Lu 2006-03-23 12:59:59 EST
It only happens when host exports more subdirectories:

gnu-1:/export         59106976  46132392   9972040  83% /net/gnu-1/export
gnu-1:/export/server  76920416  19143280  57773040  25% /net/gnu-1/export/server
Comment 2 Ahmon Dancy 2006-04-12 18:04:07 EDT
This happens to me as well, under the same circumstances (host exports multiple
filesystems).  autofs never times out the mounts.  killall -v -USR1 automount
does cause the unused filesystems to be unmounted.  
Comment 3 Jeffrey Moyer 2006-04-17 18:44:27 EDT
Ian, do you want to take a look at this?
Comment 4 Ian Kent 2006-04-18 09:18:10 EDT
(In reply to comment #0)
> With autofs-4.1.4-16.2.2, autofs never umounts /net/host/dir after I did
> 
> # cd /net/host/dir
> # ls
> # cd /

I'm really going to need more information on this.

Could you have a look at Jeff Moyers people page and put together
the version information and a debug log as decsribed their please.
Comment 5 Jeffrey Moyer 2006-04-18 09:29:09 EDT
Ian is referring to this URL:

  http://people.redhat.com/jmoyer/

thanks.
Comment 6 H.J. Lu 2006-04-18 11:58:40 EDT
Created attachment 127931 [details]
/var/log/debug

In /var/log/messages:

Apr 18 08:56:36 gnu-10 automount[9463]: starting automounter version
4.1.4-16.2.2, path = /net, maptype = program, mapname = /etc/auto.net
Apr 18 08:56:36 gnu-10 automount[9463]: using kernel protocol version 4.07
Apr 18 08:56:36 gnu-10 automount[9463]: using timeout 60 seconds; freq 15 secs
Apr 18 08:56:59 gnu-10 automount[9463]: attempting to mount entry /net/gnu-1
Apr 18 08:58:05 gnu-10 automount[9501]: rm_unwanted: /net/gnu-1/export
Apr 18 08:58:05 gnu-10 automount[9501]: rm_unwanted: /net/gnu-1
Apr 18 08:58:05 gnu-10 automount[9501]: expired /net/gnu-1
Apr 18 08:58:05 gnu-10 automount[9463]: attempting to mount entry /net/gnu-1
Apr 18 08:59:20 gnu-10 automount[9522]: rm_unwanted: /net/gnu-1/export
Apr 18 08:59:20 gnu-10 automount[9522]: rm_unwanted: /net/gnu-1
Apr 18 08:59:20 gnu-10 automount[9522]: expired /net/gnu-1
Apr 18 08:59:20 gnu-10 automount[9463]: attempting to mount entry /net/gnu-1
Apr 18 09:00:35 gnu-10 automount[9542]: rm_unwanted: /net/gnu-1/export
Apr 18 09:00:35 gnu-10 automount[9542]: rm_unwanted: /net/gnu-1
Apr 18 09:00:35 gnu-10 automount[9542]: expired /net/gnu-1
Apr 18 09:00:35 gnu-10 automount[9463]: attempting to mount entry /net/gnu-1
Apr 18 09:02:50 gnu-10 automount[9571]: rm_unwanted: /net/gnu-1/export
Apr 18 09:02:50 gnu-10 automount[9571]: rm_unwanted: /net/gnu-1
Apr 18 09:02:50 gnu-10 automount[9571]: expired /net/gnu-1
Apr 18 09:02:50 gnu-10 automount[9463]: attempting to mount entry /net/gnu-1
Comment 7 H.J. Lu 2006-04-18 12:01:07 EDT
Created attachment 127932 [details]
/var/log/debug

In /var/log/messages:

Apr 18 08:56:36 gnu-10 automount[9463]: starting automounter version
4.1.4-16.2.2, path = /net, maptype = program, mapname = /etc/auto.net
Apr 18 08:56:36 gnu-10 automount[9463]: using kernel protocol version 4.07
Apr 18 08:56:36 gnu-10 automount[9463]: using timeout 60 seconds; freq 15 secs
Apr 18 08:56:59 gnu-10 automount[9463]: attempting to mount entry /net/gnu-1
Apr 18 08:58:05 gnu-10 automount[9501]: rm_unwanted: /net/gnu-1/export
Apr 18 08:58:05 gnu-10 automount[9501]: rm_unwanted: /net/gnu-1
Apr 18 08:58:05 gnu-10 automount[9501]: expired /net/gnu-1
Apr 18 08:58:05 gnu-10 automount[9463]: attempting to mount entry /net/gnu-1
Apr 18 08:59:20 gnu-10 automount[9522]: rm_unwanted: /net/gnu-1/export
Apr 18 08:59:20 gnu-10 automount[9522]: rm_unwanted: /net/gnu-1
Apr 18 08:59:20 gnu-10 automount[9522]: expired /net/gnu-1
Apr 18 08:59:20 gnu-10 automount[9463]: attempting to mount entry /net/gnu-1
Apr 18 09:00:35 gnu-10 automount[9542]: rm_unwanted: /net/gnu-1/export
Apr 18 09:00:35 gnu-10 automount[9542]: rm_unwanted: /net/gnu-1
Apr 18 09:00:35 gnu-10 automount[9542]: expired /net/gnu-1
Apr 18 09:00:35 gnu-10 automount[9463]: attempting to mount entry /net/gnu-1
Apr 18 09:02:50 gnu-10 automount[9571]: rm_unwanted: /net/gnu-1/export
Apr 18 09:02:50 gnu-10 automount[9571]: rm_unwanted: /net/gnu-1
Apr 18 09:02:50 gnu-10 automount[9571]: expired /net/gnu-1
Apr 18 09:02:50 gnu-10 automount[9463]: attempting to mount entry /net/gnu-1
Comment 8 Ahmon Dancy 2006-04-18 13:07:15 EDT
kernel-2.6.16-1.2080_FC5
autofs-4.1.4-16.2.2
Comment 9 Ahmon Dancy 2006-04-24 14:02:13 EDT
Created attachment 128157 [details]
Patch which removes the problem

Attached is a patch that one of my coworkers created which remedies the problem
(and probably supplies enough information to get to the root cause).
Comment 10 John Foderaro 2006-04-24 14:12:31 EDT
See also bug 189535 where the same problem is being discussed.
Comment 11 Ian Kent 2006-04-25 00:35:06 EDT
(In reply to comment #9)
> Created an attachment (id=128157) [edit]
> Patch which removes the problem
> 
> Attached is a patch that one of my coworkers created which remedies the problem
> (and probably supplies enough information to get to the root cause). 
> 

I must admit it's tempting to apply this patch without further
fuss as I have commented these calls out in the version 5 development
for other less important reasons to see if there's a regression. So
I'd really like to wait till I've had a chance to test this out for
for a while.

The other concern is that this hasn't changed between the FC4 and
FC5 packages. So either a recent kernel patch has caused it or 
a process other than a GUI is responding to filesystem changes which
could have further implications.




Comment 12 H.J. Lu 2006-04-26 01:52:48 EDT
2.6.16-1.2096_FC4 and autofs-4.1.4-15.1 on FC4 have no problems. I rebuilt
and installed autofs-4.1.4-15.1 on FC5. It doesn't solve the problem.
Comment 13 H.J. Lu 2006-04-26 21:29:58 EDT
I installed 2.6.16-1.2096_FC4 and autofs-4.1.4-15.1 on FC5. The problem
still persists. So the cause is somewhere else.
Comment 14 H.J. Lu 2006-04-26 21:56:43 EDT
After I ran

[root@gnu-65 log]# /etc/init.d/haldaemon stop

the problem went away.
Comment 15 Ian Kent 2006-04-26 22:44:02 EDT
(In reply to comment #14)
> After I ran
> 
> [root@gnu-65 log]# /etc/init.d/haldaemon stop
> 
> the problem went away.

Excellent work.

I really couldn't see anything autofs that would cause this.
I'll check into this.

Thanks.
Ian
Comment 16 Ian Kent 2006-05-29 22:29:40 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > After I ran
> > 
> > [root@gnu-65 log]# /etc/init.d/haldaemon stop
> > 
> > the problem went away.
> 
> Excellent work.
> 
> I really couldn't see anything autofs that would cause this.
> I'll check into this.

Can you try the latest version of the HAL package please.
I believe this problem is fixed.

Ian
Comment 17 H.J. Lu 2006-05-30 11:44:44 EDT
What is the latest verion of HAL? I am runnig hal-0.5.7-3.fc5.1.
Comment 18 Ian Kent 2006-05-31 00:17:31 EDT
(In reply to comment #17)
> What is the latest verion of HAL? I am runnig hal-0.5.7-3.fc5.1.

Sorry, I'm a bit impacient.
I see the fix is currently in the Rawhide version.
I'll let you know when it makes it into fc5.

Ian
Comment 19 Ian Kent 2006-06-21 21:10:23 EDT
(In reply to comment #18)
> (In reply to comment #17)
> > What is the latest verion of HAL? I am runnig hal-0.5.7-3.fc5.1.
> 
> Sorry, I'm a bit impacient.
> I see the fix is currently in the Rawhide version.
> I'll let you know when it makes it into fc5.
> 

This version of HAL appears to be have been in FC-5 for a
while now, sorry I didn't let you know earlier.

Can you check that this problem is now resolved.


Comment 20 H.J. Lu 2006-06-21 22:36:11 EDT
hal-0.5.7-3.fc5.2 fixes the problem.

Note You need to log in before you can comment on or make changes to this bug.