Bug 186459 - dual head does not work with FireGL X1
dual head does not work with FireGL X1
Status: CLOSED DUPLICATE of bug 198955
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 13:08 EST by Stephen Adler
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 18:13:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.conf file for Radeon MergedFB configuration with two LCD panels (5.78 KB, text/plain)
2006-03-27 09:53 EST, Sean E. Millichamp
no flags Details
Xorg.0.log running my working MergedFB configuration (143.20 KB, text/plain)
2006-03-27 10:11 EST, Sean E. Millichamp
no flags Details
Xorg.0.log file running with the config generated from system-config-display (49.48 KB, text/plain)
2006-03-27 10:12 EST, Sean E. Millichamp
no flags Details
xorg.conf generated by system-config-display for spanning desktops (3.40 KB, text/plain)
2006-03-27 10:14 EST, Sean E. Millichamp
no flags Details

  None (edit)
Description Stephen Adler 2006-03-23 13:08:51 EST
Description of problem:

I have a FireGL X1 with dual dvi outputs, each output attached to a monitor.
Under FC3, I was able to run the two monitors in xinerama mode. Now with FC5, it
does not work.


Version-Release number of selected component (if applicable):


How reproducible:

every time

Steps to Reproduce:
1. Install FC5
2. Configure the display to use dual head 'spanning desktops' mode.
  
Actual results:

The desktop or display does see the spanning desktop size, but
paints the first half of the desktop on the second half. The
cursor will drag over to the second side of the desk top
on the 2nd monitor, so it looks like the mouse is working ok.


Expected results:

Properly functioning 'spanning desktop'

Additional info:
Comment 1 Sean E. Millichamp 2006-03-24 10:54:18 EST
I can confirm this problem.  On a first glance, it seemed that it was using
clone mode instead of spanning desktop but it actually looks like it is using
some broken combination.

I see the first screen mirrored on the second screen, though (as the original
reporter said) the mouse is only ever on one screen at a time.  However, if you
look in the Gnome Workplace Switcher you will see that the system has configured
a virtual desktop space large enough for a spanning-desktop configuration.  It
is just the second half is not viewable.  Applications seem to open into the
invisiable second half of the desktop without problems (well, except for not
being able to see them).

I was able to work around this by manually configuring /etc/X11/xorg.conf to use
MergedFB mode but the normal dual head mode definitely seems broken in the
radeon driver.
Comment 2 Mike A. Harris 2006-03-24 18:19:14 EST
Thanks for the report.  We have reviewed the information you
have provided above, and there is some additional information we
require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log) to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link
below.

We will review this issue again once you've had a chance to attach
this information.

Thanks in advance.
Comment 5 Juan A. Burgos 2006-03-27 02:44:34 EST
Sean could you please post your working xorg.conf file.
Comment 6 Sean E. Millichamp 2006-03-27 09:53:50 EST
Created attachment 126819 [details]
Xorg.conf file for Radeon MergedFB configuration with two LCD panels
Comment 7 Sean E. Millichamp 2006-03-27 09:55:45 EST
You should note that even though the first line in my configuration file says it
was created with system-config-display that is only partially true.  The initial
file was created with the tool, but when I couldn't get spanning desktops to
work the way the tool configured it I pursued the MergedFB route and ended up
following some configuration snippets I saw on a mailing list archive somewhere.

That is the exact file I am running with at this moment.
Comment 8 Sean E. Millichamp 2006-03-27 10:11:07 EST
Created attachment 126820 [details]
Xorg.0.log running my working MergedFB configuration
Comment 9 Sean E. Millichamp 2006-03-27 10:12:50 EST
Created attachment 126823 [details]
Xorg.0.log file running with the config generated from system-config-display
Comment 10 Sean E. Millichamp 2006-03-27 10:14:06 EST
Created attachment 126825 [details]
xorg.conf generated by system-config-display for spanning desktops
Comment 11 Matěj Cepl 2007-07-04 18:13:19 EDT

*** This bug has been marked as a duplicate of 198955 ***

Note You need to log in before you can comment on or make changes to this bug.