Bug 186496 - Nautilus hangs when accessing an sftp bookmark
Nautilus hangs when accessing an sftp bookmark
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 16:13 EST by Bryan Christ
Modified: 2015-03-03 17:28 EST (History)
3 users (show)

See Also:
Fixed In Version: Fedora 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 17:17:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Christ 2006-03-23 16:13:42 EST
Description of problem:

Nautilus hangs when accessing an sftp bookmark.  When this happens, Nautilus
must be restarted.

Version-Release number of selected component (if applicable):

nautilus-2.14.0-1
gnome-vfs2-2.14.0-1

How reproducible:

every time

Steps to Reproduce:
1.  Open an Nautilus file browser
2.  Choose Go->Location
3.  Type in sftp://username@your_server.fqdn.com:/home/username
4.  Enter password
5.  Click Bookmarks->Add bookmark
6.  Make Nautilus "forget" your session credentials (logout of Gnome and back
in, or close window and wait a while).
7.  Try to access the sftp location with your bookmark.
8.  See Nautilus hang.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bryan Christ 2006-04-04 11:28:16 EDT
Not sure what component was the culprit, but this problem disappeared after I
did a recent update via yum.
Comment 2 John Thacker 2006-04-19 01:47:24 EDT
If the problem is fixed, then let's close the bug.
Comment 3 Bryan Christ 2006-04-19 10:23:51 EDT
It was fixed, but I did an update via yum early last week and it looks like the
problem is back.
Comment 4 John Thacker 2006-04-27 17:57:30 EDT
BTW, I saw a version of this problem, but in a situation where I had 
created an sftp bookmark to a site which later had sftp service 
turned off.   It wouldn't let me create a new bookmark to the site,
since it couldn't make the sftp connection, but if I tried to use
my old bookmark it would hang.

In any case, can you test this with the new gnome-vfs2-2.14.1-1.fc5.2 
update which was just released?  It has some fixes to improve sftp 
performance.
Comment 5 Bryan Christ 2006-04-28 11:14:51 EDT
John,

I upgraded to gnome-vfs2-2.14.1-1.fc5.2 via yum.  Then I logged out of my gnome
session and issued an init 3.  I then brought the system back up to runlevel 5
and logged in to gnome.  (I just wanted to be throughly sure that any new
libraries were being reloaded)

I clicked on my bookmark and it did not work--Nautlius hanged.  After restarting
Nautilus, I tried doing (from the menu) Go->Location... and then entered
username@server.fqdn.com:/home/username Nautilus hung in the same way it did
when trying to use the bookmark.

Now I know this is not a problem which is unique to my server because it happens
with other servers that I have access to.  Also, I doubt there is any ssh
configuration problems on the server because I can successfully connect to my
server using the sshfs fuse module--and it works flawlessly.
Comment 6 Bryan Christ 2006-04-28 11:16:42 EDT
oops... correction to comment #5...  the path I entered into Go->Locataion was
actually sftp://username@server.fqdn.com:/home/username
Comment 7 John Thacker 2006-04-28 11:23:34 EDT
Are you sure that you can *sftp* to the site, as oppose to ssh?
I'm just asking because I have exactly the same behavior on a server
which was recently upgraded and had sftp support turned off.  The
default for sshd is no sftp subsystem loaded, though I believe that
the Fedora default adds the line in sshd_config to turn it on.

When I try to sftp from the command line, I get:

Request for subsystem 'sftp' failed on channel 0
Couldn't read packet: Connection reset by peer

and Nautilus hangs in exactly the same way as you describe.
I can ssh, scp, etc. to that server perfectly.  It's entirely 
possible to be able to ssh to a server (and scp, and use sshfs)
but not be able to sftp.  Nautilus uses sftp instead of ssh to
display things.

What happens if you try to sftp from the command line to site?
Comment 8 Bryan Christ 2006-04-28 12:37:39 EDT
I am 100% certain sftp is enabled.  Just to be certain, sftp (the command line
tool) works perfectly.

Now the crazy part, if I removed my bookmarks from Nautilus, using
Go->Location... works perfectly every time.  I am beginning to wonder if there
is some faulty interaction between Nautilus and gnome-keyring.

Yet another anomolie is that the Nautilus "Connect to server..." feature works
perfectly also (although I suspect ssh/scp might be the mechanism there).

Comment 9 Alexander Larsson 2006-09-04 12:08:30 EDT
Nah, "Connect to server" just creates a link to a sftp:// uri. Very strange.
Comment 10 Bryan Christ 2006-09-05 11:20:21 EDT
I just retested this bug last week after bringing my FC5 system up to date via
yum and the issue still remains--exactly as described here in this bugzilla.
Comment 11 Matthias Clasen 2006-09-22 22:09:42 EDT
Might be related to http://bugzilla.gnome.org/show_bug.cgi?id=356717
Comment 12 Bryan Christ 2006-09-26 12:43:01 EDT
Matthias,

Have you been able to reproduced this bug on your end?
Comment 13 petrosyan 2008-03-10 23:28:14 EDT
Fedora Core 5 is no longer maintained. Is this bug still present in Fedora 7 or
Fedora 8?
Comment 14 Bryan Christ 2008-03-11 14:38:20 EDT
I haven't tried it in a while, but I'll try it this week on Fedora 8.
Comment 15 Bryan Christ 2008-03-13 13:01:00 EDT
I retested this today and the problem seems to have gone away.  I haven't been
using the bookmark feature like this in a while (because of this bug).  Instead
I've been using the "Connect to Server" method instead.  I'll keep using the
bookmark feature now and if I don't have any more failures to report in the next
two weeks I would recommend closing this BZ.
Comment 16 petrosyan 2008-03-31 11:26:56 EDT
What is the status of this bug? Are you still able to reproduce it?
Comment 17 Bug Zapper 2008-04-03 22:13:39 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 18 Bryan Christ 2008-04-04 10:45:39 EDT
I have retested this several times on Fedora 8 with all of the latest stable
updates.  I do not see the problem anymore.
Comment 19 John Poelstra 2008-04-10 17:09:19 EDT
Thanks for your update.

Note You need to log in before you can comment on or make changes to this bug.