Bug 186504 - error while loading shared libraries
error while loading shared libraries
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 17:16 EST by Gianluca Busco
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 14:17:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gianluca Busco 2006-03-23 17:16:54 EST
Description of problem:
After a new (scratch) FC5 installation and I noticed some shared libraries
problems. I tried to install some Java applications (Borland Star Team for
example..) but I receive this error:

awk: error while loading shared libraries: libdl.so.2: cannot open shared object
file: No such file or directory
dirname: error while loading shared libraries: libc.so.6: cannot open shared
object file: No such file or directory
/bin/ls: error while loading shared libraries: librt.so.1: cannot open shared
object file: No such file or directory
basename: error while loading shared libraries: libc.so.6: cannot open shared
object file: No such file or directory
dirname: error while loading shared libraries: libc.so.6: cannot open shared
object file: No such file or directory
basename: error while loading shared libraries: libc.so.6: cannot open shared
object file: No such file or directory
hostname: error while loading shared libraries: libc.so.6: cannot open shared
object file: No such file or directory

Version-Release number of selected component (if applicable):

How reproducible:
If you try to install some Java applications.


Additional info:
Comment 1 Thomas Fitzsimmons 2006-03-23 17:51:23 EST
What was the installation command that you ran?
Comment 2 Gianluca Busco 2006-03-24 06:28:26 EST
(In reply to comment #1)
> What was the installation command that you ran?
> 

All Java and "bin" installation commands. If I try to install any Java based
application or any "bin" executable command I receive the error reported. I
think that this error is caused by Java setting the environment variable
LD_ASSUME_KERNEL for its context which is incompatible with commands launched
from the Java environment

gianluca
Comment 3 Gianluca Busco 2006-03-24 06:54:42 EST
ok, I found a temporary workaround.. but I don't know if this solution is the
best way to solve the problem.

$ cp MyInstallSetup.bin MyInstallSetup.bin.save

$ cat MyInstallSetup.bin.save | \

   sed "s/export LD_ASSUME_KERNEL/#xport LD_ASSUME_KERNEL/" > \

   MyInstallSetup.bin

Now, MyInstallSetup.bin works fine but I'll need to repeat this boring operation
for any new java applications...

gianluca 
Comment 4 Gianluca Busco 2006-03-27 14:39:41 EST
Another bit...
I installed the "compat-libstdc++-33" RPM and the problem was solved but I've
not understood why this rpm was not installed on FC5 setup...

gianluca 

Note You need to log in before you can comment on or make changes to this bug.