Bug 186523 - bind 9.3.2-12 does not get installed due to missing dep in System-config-bind
bind 9.3.2-12 does not get installed due to missing dep in System-config-bind
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 20:41 EST by Marc Wiriadisastra
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 11:15:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc Wiriadisastra 2006-03-23 20:41:07 EST
Description of problem:
When I try to update to Bind-9.3.2-12 I can't update because system-config-bind
requires Bind-9.3.2-10

How reproducible:
Always reproducible

Steps to Reproduce:
1. yum -y update
2. yum -y upgrade
3. error on dependancies
  
Actual results:
An error is generated: Missing Dependency: bind = 30:9.3.2-10.FC5 is needed by
package bind-config


Expected results:

bind will be updated.

This is with a default Fedora Core 5 install.
Comment 1 Jason Vas Dias 2006-03-24 13:13:45 EST
Very strange - I cannot reproduce this problem here, 
on a new clean-installed FC-5 system, 
with the default /etc/yum.conf file.

bind-config is a sub-package of the bind main package; it replaces 
caching-nameserver, and depends only on %{epoch}:bind-%{version}-%{release}.

I had the bind-*9.3.2-10_FC5 packages installed:

$ rpm -qa 'bind*'
bind-config-9.3.2-10.FC5
bind-utils-9.3.2-10.FC5
bind-sdb-9.3.2-10.FC5
bind-libbind-devel-9.3.2-10.FC5
bind-libs-9.3.2-10.FC5
bind-9.3.2-10.FC5
bind-devel-9.3.2-10.FC5
$ yum update
...

--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
...
 bind                    i386       30:9.3.2-12.FC5  core              929 k
 bind-config             i386       30:9.3.2-12.FC5  core               50 k
 bind-devel              i386       30:9.3.2-12.FC5  core              2.5 M
 bind-libbind-devel      i386       30:9.3.2-12.FC5  core              433 k
 bind-libs               i386       30:9.3.2-12.FC5  core              833 k
 bind-sdb                i386       30:9.3.2-12.FC5  core              215 k
 bind-utils              i386       30:9.3.2-12.FC5  core              155 k
...
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : bind-libs                    ####################### [ 1/51]
  Updating  : bind                         ####################### [ 9/51]
  Updating  : bind-utils                   ####################### [10/51]
  Updating  : bind-sdb                     ####################### [14/51]
  Updating  : bind-config                  ####################### [15/51]
  Updating  : bind-devel                   ####################### [17/51]
  Updating  : bind-libbind-devel           ####################### [18/51]
...
  Cleanup   : bind-devel                   ####################### [27/51]
  Cleanup   : bind-libs                    ####################### [28/51]
  Cleanup   : bind-config                  ####################### [30/51]
  Cleanup   : bind-libbind-devel           ####################### [34/51]
  Cleanup   : bind                         ####################### [42/51]
  Cleanup   : bind-utils                   ####################### [43/51]
  Cleanup   : bind-sdb                     ####################### [46/51]
...
Updated: ... bind.i386 30:9.3.2-12.FC5 bind-config.i386 30:9.3.2-12.FC5
bind-devel.i386 30:9.3.2-12.FC5 bind-libbind-devel.i386 30:9.3.2-12.FC5
bind-libs.i386 30:9.3.2-12.FC5 bind-sdb.i386 30:9.3.2-12.FC5 bind-utils.i386
30:9.3.2-12.FC5...
Complete!
$ rpm -qa 'bind*'
bind-config-9.3.2-12.FC5
bind-utils-9.3.2-12.FC5
bind-sdb-9.3.2-12.FC5
bind-libbind-devel-9.3.2-12.FC5
bind-libs-9.3.2-12.FC5
bind-9.3.2-12.FC5
bind-devel-9.3.2-12.FC5


Please send me your yum.conf file and a similar transcript to that above 
showing the problem; also the yum messages from /var/log/messages might
be useful in resolving this issue:
# grep yum /var/log/messages

Thank you!
Comment 2 Marc Wiriadisastra 2006-03-24 22:58:52 EST
[root@localhost ~]#  rpm -qa 'bind*'
bind-libs-9.3.2-12.FC5
bind-utils-9.3.2-12.FC5
bind-9.3.2-10.FC5
bind-config-9.3.2-10.FC5
bind-utils-9.3.2-10.FC5
bind-config-9.3.2-12.FC5

[root@localhost ~]# cat /etc/yum.conf
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d

I tried it again and this is the bottom bit.

--> Running transaction check
--> Processing Dependency: bind = 30:9.3.2-10.FC5 for package: bind-config
--> Processing Dependency: gstreamer-tools >= 0.10.4 for package: gstreamer
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for gstreamer-tools to pack into transaction set.
gstreamer-tools-0.10.4-1. 100% |=========================|  12 kB    00:00
---> Package gstreamer-tools.i386 0:0.10.4-1 set to be updated
--> Running transaction check
--> Processing Dependency: bind = 30:9.3.2-10.FC5 for package: bind-config
--> Finished Dependency Resolution
Error: Missing Dependency: bind = 30:9.3.2-10.FC5 is needed by package bind-config

[root@localhost log]# grep yum /var/log/messages
Mar 23 13:32:53 localhost yum: Installed: yumex.noarch 0.99.14-1.0.fc5
Mar 23 14:14:41 localhost yum: Installed: ntfs-kmod-common.noarch 2.1.26-2.lvn5
Mar 23 14:14:49 localhost yum: Installed: kmod-ntfs.i686 2.1.26-3.2.6.15_1.2054_FC5
Mar 23 14:20:22 localhost yum: Installed: wine.i386 0.9.10-2.fc5
Mar 23 14:36:50 localhost yum: Installed: faac.i386 1.24-4.lvn5
Mar 23 14:36:54 localhost yum: Installed: gsm.i386 1.0.10-10.lvn5
Mar 23 14:36:59 localhost yum: Installed: imlib2.i386 1.2.1-5.fc5
Mar 23 14:37:04 localhost yum: Installed: ffmpeg.i386 0.4.9-0.20.20051228.lvn5
Mar 23 14:37:09 localhost yum: Installed: libquicktime.i386 0.9.7-9.lvn5
Mar 23 15:52:41 localhost yum: Installed: compat-wxGTK-common.i386 2.4.2-17.fc5
Mar 23 15:53:01 localhost yum: Installed: compat-wxGTK2.i386 2.4.2-17.fc5
Mar 23 15:53:02 localhost yum: Installed: compat-wxGTK2-gl.i386 2.4.2-17.fc5
Mar 23 15:53:28 localhost yum: Installed: wxPythonGTK2.i386 2.4.2.4-7
Mar 23 15:59:05 localhost yum: Installed: wxGTK.i386 2.6.2-5.fc5
Mar 23 16:14:26 localhost yum: Updated: sendmail.i386 8.13.6-0.FC5.1

Hope this helps. This install was a brand new install not upgraded at all.  Only
additions to the packages is livna
Comment 3 Marc Wiriadisastra 2006-03-24 23:07:58 EST
Bit more info for you specifically on the updating of bind.

[root@localhost ~]# yum update bind
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/4]
core                                                                 [2/4]
updates                                                              [3/4]
extras                                                               [4/4]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package bind.i386 30:9.3.2-12.FC5 set to be updated
--> Running transaction check
--> Processing Dependency: bind = 30:9.3.2-10.FC5 for package: bind-config
--> Finished Dependency Resolution
Error: Missing Dependency: bind = 30:9.3.2-10.FC5 is needed by package bind-config
[root@localhost ~]#
Comment 4 Jason Vas Dias 2006-03-26 14:00:26 EST
Aha! Thanks - I see the problem now.

You cannot just 'yum update bind' - this tries to update ONLY the 'bind'
main package without all the packages that depend upon the bind-$V-$R, such
as bind-utils, bind-chroot, bind-config, etc.

If you just do a 
# yum update
or a
# yum update 'bind*'
then the update should work correctly.

The bind sub-packages, such as bind-chroot, have always had the dependency:
'Requires: %{epoch}:bind-%{version}-%{release}
'
Perhaps I'll consider changing that to 
'Requires: bind
'
But still, while then a 'yum update bind' would work, you'd be left with
eg. both bind-9.3.2-12.FC5 and bind-config-9.3.2-10.FC5 installed.

Is there any reason why you can't do a 
# yum update
or 
# yum update 'bind*' ?
Comment 5 Marc Wiriadisastra 2006-03-26 23:15:39 EST
I only did yum update bind for illustrative purposes.  When I do yum update or
yum update 'bind' the result is still the same as listed below.

[root@localhost ~]# yum update 'bind*'
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/4]
livna                     100% |=========================|  951 B    00:00
core                                                                 [2/4]
http://fedora.ngi.it/5/i386/os/repodata/repomd.xml: [Errno 14] HTTP Error 503:
Date: Mon, 27 Mar 2006 04:17:04 GMT
Server: Apache
Content-Length: 421
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
core                      100% |=========================| 1.1 kB    00:00
updates                                                              [3/4]
updates                   100% |=========================|  951 B    00:00
extras                                                               [4/4]
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  46 kB    00:01
updates   : ################################################## 140/140
Added 64 new packages, deleted 0 old in 1.19 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for bind to pack into transaction set.
bind-9.3.2-12.FC5.i386.rp 100% |=========================|  41 kB    00:01
---> Package bind.i386 30:9.3.2-12.FC5 set to be updated
--> Running transaction check
--> Processing Dependency: bind = 30:9.3.2-10.FC5 for package: bind-config
--> Finished Dependency Resolution
Error: Missing Dependency: bind = 30:9.3.2-10.FC5 is needed by package bind-config
[root@localhost ~]#

The output from the other command.

[root@localhost ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/4]
core                                                                 [2/4]
updates                                                              [3/4]
extras                                                               [4/4]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package bind.i386 30:9.3.2-12.FC5 set to be updated
--> Running transaction check
--> Processing Dependency: bind = 30:9.3.2-10.FC5 for package: bind-config
--> Finished Dependency Resolution
Error: Missing Dependency: bind = 30:9.3.2-10.FC5 is needed by package bind-config
[root@localhost ~]#

In saying that however I run 3-4 fedora machines and this machine is the only
one with the issue. I'm not sure how I got it on this machine and why its not on
others.

Is there a way to fix it if its still only this machine?
Comment 6 Jason Vas Dias 2006-03-27 13:09:51 EST
I've tried to reproduce this problem on 3 FC-5 machines, but cannot.

Are you sure yum and rpm are up2date on the machine where the problem occurs ?
(should be yum-2.6.0-1, rpm-4.4.2-15.2).

Was the machine on which the problem occurs clean-installed as FC-5, or 
upgraded from a previous release, eg. FC-4 / FC5testX ?

You should not have any of these packages installed:
---
# rpm -q rpmdb-{redhat,fedora}
package rpmdb-redhat is not installed
package rpmdb-fedora is not installed
---
as they are now deprecated in FC-5 - having them installed could be a problem.

It is very easy to resolve this problem for the one machine on which it occurs:

# mkdir /tmp/bu
# cd /tmp/bu
# wget \
'ftp://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/i386/bind*9.3.2-12.FC5.i386.rpm'
# rpm -Uvh --force bind-*
Comment 7 Marc Wiriadisastra 2006-03-27 20:07:08 EST
[root@localhost ~]# rpm -qa yum
yum-2.6.0-1
[root@localhost ~]#

[root@localhost ~]# rpm -qa rpm
rpm-4.4.2-15.2
[root@localhost ~]#

[root@localhost ~]# rpm -q rpmdb-{redhat,fedora}
package rpmdb-redhat is not installed
package rpmdb-fedora is not installed
[root@localhost ~]#

I run 3 machines.  2 were clean installed one was an upgrade.  1 of the clean
machines has this issue the other 2 do not.

As I said this issue is with a clean install which is what has me confused.  I
will fix the issue the way you pointed out. However all the information you have
asked me to provide is exactly the same as yours so I'm even more confused now
than before :(

I suppose just close the bug however yeah not sure what happened to be honest.
Comment 8 Jason Vas Dias 2006-03-28 11:15:28 EST
Yes, this is very perplexing - I cannot duplicate the problem on any 
clean installed or upgraded FC-5 machine.

Perhaps the machine on which the problem occurs may have a corrupt
rpm db ? Did you ever abort a yum session ? 
Does doing a 'rpmdb --rebuilddb' fix the problem ?

Anyway, I'm confident this problem cannot be caused by anything in the
bind packages - so closing as 'NOTABUG'.

Note You need to log in before you can comment on or make changes to this bug.