Bug 186529 - sizeof(I830DRIRec) mismatch when running glxgears causes Xorg crash
Summary: sizeof(I830DRIRec) mismatch when running glxgears causes Xorg crash
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-24 02:34 UTC by Luke Macken
Modified: 2016-09-20 02:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 21:45:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glxinfo.strace (23.24 KB, text/plain)
2006-03-24 02:34 UTC, Luke Macken
no flags Details
Xorg.0.log (63.59 KB, text/plain)
2006-03-26 01:07 UTC, Luke Macken
no flags Details
xorg.conf (2.96 KB, text/plain)
2006-03-26 01:07 UTC, Luke Macken
no flags Details

Description Luke Macken 2006-03-24 02:34:33 UTC
Description of problem:
Running `glxinfo` causes my xserver to crash with the following error:
ERROR!  sizeof(I830DRIRec) does not match passed size from device driver
libGL warning: 3D driver returned no fbconfigs.

Version-Release number of selected component (if applicable):
Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
xorg-x11-server-Xorg-1.0.99.1-2
xorg-x11-drv-i810-1.4.1.3-4.cvs20060322


How reproducible:
Always

Comment 1 Luke Macken 2006-03-24 02:34:33 UTC
Created attachment 126595 [details]
glxinfo.strace

Comment 2 Mike A. Harris 2006-03-24 23:08:50 UTC
Please attach your X server log and config file.



Comment 3 Luke Macken 2006-03-26 01:07:04 UTC
Created attachment 126743 [details]
Xorg.0.log

Comment 4 Luke Macken 2006-03-26 01:07:55 UTC
Created attachment 126744 [details]
xorg.conf

Comment 5 Adam Jackson 2006-09-20 21:45:48 UTC
I'm unable to reproduce this with test3.  Please reopen if this is still an
issue for you.


Note You need to log in before you can comment on or make changes to this bug.