Bug 186538 - kudzu segfault
kudzu segfault
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 01:59 EST by Roberto Malinverni
Modified: 2014-03-16 22:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: 1.2.41-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 18:48:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of "strace kudzu" (81.94 KB, text/plain)
2006-03-24 01:59 EST, Roberto Malinverni
no flags Details
A similar trace from my new Dell PowerEdge 430SC Server (65.82 KB, text/plain)
2006-03-24 08:46 EST, Phil Anderson
no flags Details
Strace of Kudzu when it segfaults (67.69 KB, text/plain)
2006-03-28 19:54 EST, Chris Wailes
no flags Details
strace kudzu (64.93 KB, text/plain)
2006-03-31 14:59 EST, Johan Kröckel
no flags Details
gdb traceback at SIGSEGV from "kudzu --probe" (3.46 KB, text/plain)
2006-04-11 23:25 EDT, John Reiser
no flags Details
valgrind output of "kudzu --probe" (4.18 KB, text/plain)
2006-04-11 23:42 EDT, John Reiser
no flags Details

  None (edit)
Description Roberto Malinverni 2006-03-24 01:59:29 EST
Description of problem:
Kudzu segfaults at boot and when run from command line

Version-Release number of selected component (if applicable):
stock version of kudzu shipped with FC5; tried even kudzu versions 1.2.26/1.2.27
found on http://people.redhat.com/notting/kudzu/.
Tested with FC5 i686 smp kernel and with kernels up/smp 2.6.16_2070 found on
http://people.redhat.com/davej/kernels/Fedora/FC5/RPMS.kernel/

How reproducible:
boot the system or run kudzu from command line

Steps to Reproduce:
1.
2.
3.
  
Actual results:
kudzu segfaults

Expected results:
kudzu runs normally

Additional info:
FC5 is a fresh install.
The same problem started to happen at some point with FC4; it was solved by
downgrading kudzu to 1.1.95 found on http://people.redhat.com/notting/kudzu.
Below there is a strace log.
Comment 1 Roberto Malinverni 2006-03-24 01:59:29 EST
Created attachment 126606 [details]
log of "strace kudzu"
Comment 2 Phil Anderson 2006-03-24 08:46:28 EST
Created attachment 126624 [details]
A similar trace from my new Dell PowerEdge 430SC Server

I can confirm that I too am having kudzu segfault when booting a clean FC5
install.
Comment 3 Bill Nottingham 2006-03-24 11:26:37 EST
What sort of video hardware do you have?

Phil - you're on x86_64, correct?
Comment 4 Phil Anderson 2006-03-24 17:22:33 EST
Yep, kernel-2.6.15-1.2054.x86_64 on a dual core Pentium D 2.8.  1GB RAM, 2 SATA
disks - nothing else out of the ordinary.
Comment 5 Bill Nottingham 2006-03-24 17:25:05 EST
The video hardware is probably relevant here.

Also, if you can install kudzu-debuginfo and get a backtrace, that would be great.
Comment 6 Roberto Malinverni 2006-03-27 00:25:43 EST
My video card is a ATI Radeon x700 pcie.
By the way, in the meantime I tried a safe probe and kudzu succeded writing the
hwconf file. Maybe (not tried yet) doing a "diff" between the file generated
under FC4 and the new one we will see what is the problematic hardware here (the
two FC versions are on the same PC).
Comment 7 Tim Fall 2006-03-28 06:27:00 EST
The video hardware affected seem to be high grade ATI cards (x850 in my case). Utilitizing the safe probe 
method does correctly write the file, but allowing it to subsiquently run in normal mode causes another 
segmentation fault.
Comment 8 Chris Wailes 2006-03-28 19:54:53 EST
Created attachment 126945 [details]
Strace of Kudzu when it segfaults
Comment 9 Chris Wailes 2006-03-28 19:56:39 EST
This is happening to me as well, and I was wondering if this might be causing
some other errors I am getting.

Besides the segfault, I am unable to get my Xserver out of 640X480 no matter
what I do.  Perhaps this is due to kudzu not configuring my graphics card?

Hardware:
MSI K8N Neo Platnum
AMD64 3500+ 2.2GHz
2 x Western Digital SATA Raptor
ATI Radeon X800 Pro
Comment 10 Eric Shubert 2006-03-31 11:54:24 EST
I've got this one too. My strace looks very similar, except I get a boat load of
the rt_sigprocmask and vm86old lines, like ~660K worth. Almost looks like an
infinite loop, but it does end eventually w/ SIGSEGV.
It happens with the original install, and all upgrades. I also uninstalled and
reinstalled kudzu and dependents, and problem persists.
Currently:
kernel-2.6.16-1.2080_FC5
kudzu-1.2.34.3-1
HW:
AMD Athlon 1.3GHz
PC266 SystemBoard M810 series, T-Bird chipset w/ integrated:
SiS 730 Host (rev 02)
SiS 5513 IDE (rev d0)
SiS 85C503/5513 (LPC Bridge)
SiS 900 PCI Fast Ethernet (rev 82)
SiS USB 1.0 Controller (rev 07)
SiS PCI Audio Accelerator (rev 02)
SiS AC'97 Modem Controller (rev a0)
SiS Virtual PCI-to-PCI bridge (AGP)
Additional:
SiS 630/730 PCI/AGP VGA (rev 31)
TI ACX111 54M Wireless
RTL-8169 Gigabit Ethernet

Please let me know what I might do to help.
Comment 11 Johan Kröckel 2006-03-31 14:49:04 EST
I have the same problem:
I have a sis-onboard-video-chip and a sis-chipset (741) and i386.
Comment 12 Johan Kröckel 2006-03-31 14:52:25 EST
I forgot:
FC5 fully updated.

The problem only occures when running the xen0-kernels.
Comment 13 Johan Kröckel 2006-03-31 14:59:05 EST
Created attachment 127150 [details]
strace kudzu
Comment 14 renke 2006-04-10 03:12:26 EDT
I can confirm the strange behaviour with my x86_64 (SiS-chipset)
Comment 15 John Reiser 2006-04-11 23:25:39 EDT
Created attachment 127646 [details]
gdb traceback at SIGSEGV from "kudzu --probe"

vbe_info contains uninitialized fields when vm86old() fails.
Comment 16 John Reiser 2006-04-11 23:28:15 EDT
I see SIGSEGV from "kudzu --probe" and also at boot.  The cause is uninitialized
fields in vbe_info after vm86old() fails.  Traceback is in Comment #15.

The tail of strace output is
-----
access("/proc/xen", X_OK)               = -1 ENOENT (No such file or directory)
open("/dev/zero", O_RDWR)               = 8
mmap2(0x10000, 524288, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_SHARED|MAP_FIXED, 8,
0) = 0x10000
close(8)                                = 0
open("/dev/mem", O_RDWR)                = 8
mmap2(NULL, 1282, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_SHARED|MAP_FIXED, 8, 0) = 0
mmap2(0xa0000, 393216, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_FIXED, 8, 0xa0) =
0xa0000
close(8)                                = 0
iopl(0x3)                               = 0
ioperm(0, 0x400, 0x1)                   = 0
rt_sigprocmask(SIG_SETMASK, ~[RTMIN RT_1], [], 8) = 0
vm86old(0x808910c)                      = -1 ENOSYS (Function not implemented)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
-----

Hardware is dual processor Pentium Pro 231MHz [BIOS date 1992: 14 years old.]
Video is Cirrus Logic GD 5430/40 [Apline] with 1MB: X11 running 1024x768, depth
8; no DDC.

RPMS are:
kudzu-1.2.34.3-1
kernel-2.6.16-1.2080_FC5smp
initscripts-8.31.1-1
hal-0.5.7-3

Comment 17 John Reiser 2006-04-11 23:42:47 EDT
Created attachment 127647 [details]
valgrind output of "kudzu --probe"

Even before the unknown vm86old() [syscall 113, probably the DDC probe?],
valgrind shows memory access errors.  Probably these are bugs.
Comment 18 Anthony Russell 2006-04-21 15:48:14 EDT
I was having the same problem. And it does seem related to the Ati hardware. I
my case a x700. Or better yet the driver used. Because I compled the fglrx
driver last night and now the kudzu problem seems solved.
This was done on an Acer Ferrari laptop with a fresh FC5 (64bit) install.

Maybe some one can confirm this?
Hope this is helpfull.
Comment 19 renke 2006-04-25 02:30:00 EDT
It can't be a "pure" ATI-problem - on my laptop I have the segfault with a
SiS-chipset and onboard-graphics.

Greetings, Renke
Comment 20 Russell McOrmond 2006-05-03 10:01:26 EDT
kernel-xen0-2.6.16-1.2096_FC5
udev-084-13
kudzu-1.2.34.3-1

This additional data may help:  I'm trying to tansform a machine running FC4
into a FC5+xen box.  When I first booted with the xen0 kernel it would freeze
running kudzu.  If I booted with a regular non xen-0 kernel it would boot fine.

I changed to "SAFE=yes" in /etc/sysconfig/kudzu and now the machine boots with
the Xen0 kernel.

There was a suggestion that this was potentially an ATI video card issue, but
this machine has a Matrox card in it:

from dmesg:

matroxfb: Matrox Millennium II (PCI) detected
PInS memtype = 0
matroxfb: MTRR's turned on
matroxfb: 640x480x8bpp (virtual: 640x6553)
matroxfb: framebuffer at 0xFC000000, mapped to 0xf4a00000, size 4194304
Console: switching to colour frame buffer device 80x30
fb0: MATROX frame buffer device


Note: I included the 'udev' version as the resolution/colour/etc changes when
the bootup gets to "starting udev", something that was not the case under FC4.

Comment 21 Jacek Pliszka 2006-06-04 07:04:31 EDT
Hi!

Looks like there is more than one bug here. My case:

kudzu-1.2.36-2
kernel-2.6.16-1.2122_FC5

on-board sis chipset with sis900 ethernet controller that does not work.

System just upgraded from FC3 - worked flowlessly with FC3.

kudzu bt:
Starting program: /sbin/kudzu
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0x788000

Program received signal SIGSEGV, Segmentation fault.
0x0080fd23 in strdup () from /lib/libc.so.6
(gdb) bt
#0  0x0080fd23 in strdup () from /lib/libc.so.6
#1  0x0805db6b in vbe_get_vbe_info () at vbe.c:198
#2  0x0805ace5 in ddcProbe (probeClass=Variable "probeClass" is not available.
) at ddc.c:395
#3  0x080509af in probeDevices (probeClass=CLASS_UNSPEC, probeBus=-9,
    probeFlags=1) at kudzu.c:806
#4  0x0804d576 in main (argc=Cannot access memory at address 0xffffffff
) at hwconf.c:938
#5  0x007bb724 in __libc_start_main () from /lib/libc.so.6
#6  0x0804a8c1 in _start ()

I also have a lot of vm86old lines in strace:
open("/dev/console", O_RDWR)            = 3
ioctl(3, TIOCLINUX, 0xbfa3dcab)         = 6
vm86old(0)                              = -1 EFAULT (Bad address)
access("/proc/xen", X_OK)               = -1 ENOENT (No such file or directory)
open("/dev/zero", O_RDWR)               = 7
mmap2(0x10000, 524288, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_SHARED|MAP_FIXED, 7,
0) = 0x10000
close(7)                                = 0
open("/dev/mem", O_RDWR)                = 7
mmap2(NULL, 1282, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_SHARED|MAP_FIXED, 7, 0) =
0
mmap2(0xa0000, 393216, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_FIXED, 7, 0xa0) =
0xa0000
close(7)                                = 0
iopl(0x3)                               = 0
ioperm(0, 0x400, 0x1)                   = 0
rt_sigprocmask(SIG_SETMASK, ~[RTMIN RT_1], [], 8) = 0
vm86old(0x80890cc)                      = -1 ENOSYS (Function not implemented)
...

and the last two lines repeat a lot of times.
Comment 22 Graham Leach 2006-08-06 08:14:16 EDT
kudzu barfs on my hardware too - fresh install

class: OTHER
bus: PCI
detached: 0
desc: "Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)"
vendorId: 1039
deviceId: 0001
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  2
pcifn:  0
-
class: OTHER
bus: PCI
detached: 0
driver: i2c-sis630
desc: "Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge)"
vendorId: 1039
deviceId: 0018
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  1
pcifn:  0
-
class: OTHER
bus: USB
detached: 0
desc: "Linux 2.6.17-1.2157_FC5 ohci_hcd OHCI Host Controller"
usbclass: 9
usbsubclass: 0
usbprotocol: 0
usbbus: 1
usblevel: 0
usbport: 0
usbdev: 1
vendorId: 0000
deviceId: 0000
usbmfr: Linux 2.6.17-1.2157_FC5 ohci_hcd
usbprod: OHCI Host Controller
-
class: OTHER
bus: USB
detached: 0
desc: "Linux 2.6.17-1.2157_FC5 ohci_hcd OHCI Host Controller"
usbclass: 9
usbsubclass: 0
usbprotocol: 0
usbbus: 2
usblevel: 0
usbport: 0
usbdev: 1
vendorId: 0000
deviceId: 0000
usbmfr: Linux 2.6.17-1.2157_FC5 ohci_hcd
usbprod: OHCI Host Controller
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0200"
deviceId: PNP0200
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0303"
deviceId: PNP0303
-
class: OTHER
bus: ISAPNP
detached: 0
driver: parport_pc
desc: "PNP0400"
deviceId: PNP0400
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0501"
deviceId: PNP0501
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0501"
deviceId: PNP0501
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0700"
deviceId: PNP0700
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0800"
deviceId: PNP0800
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0a03"
deviceId: PNP0a03
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0b00"
deviceId: PNP0b00
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0c01"
deviceId: PNP0c01
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0c02"
deviceId: PNP0c02
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0c04"
deviceId: PNP0c04
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0f13"
deviceId: PNP0f13
-
class: OTHER
bus: PCI
detached: 0
desc: "Silicon Integrated Systems [SiS] 730 Host"
vendorId: 1039
deviceId: 0730
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  0
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: sis900
desc: "Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet"
network.hwaddr: 00:30:18:53:43:73
vendorId: 1039
deviceId: 0900
subVendorId: 1039
subDeviceId: 0900
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  1
pcifn:  1
-
class: MOUSE
bus: PSAUX
detached: 0
device: input/mice
driver: generic3ps/2
desc: "PS/2 Generic Mouse"
-
class: CDROM
bus: IDE
detached: 0
device: hdd
desc: "SAMSUNG CD-ROM SH-152A"
-
class: VIDEO
bus: PCI
detached: 0
desc: "Silicon Integrated Systems [SiS] 630/730 PCI/AGP VGA Display Adapter"
video.xdriver: sis
vendorId: 1039
deviceId: 6300
subVendorId: 1039
subDeviceId: 6300
pciType: 1
pcidom:    0
pcibus:  1
pcidev:  0
pcifn:  0
-
class: FLOPPY
bus: MISC
detached: 0
device: fd0
desc: "3.5" 1.44MB floppy drive"
-
class: HD
bus: IDE
detached: 0
device: hda
desc: "ST340014A"
physical: 16383/16/63
logical: 16383/255/63
-
class: KEYBOARD
bus: PSAUX
detached: 0
desc: "AT Translated Set 2 keyboard"
-
class: USB
bus: PCI
detached: 0
driver: ohci-hcd
desc: "Silicon Integrated Systems [SiS] USB 1.0 Controller"
vendorId: 1039
deviceId: 7001
subVendorId: 1039
subDeviceId: 7000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  1
pcifn:  3
-
class: USB
bus: PCI
detached: 0
driver: ohci-hcd
desc: "Silicon Integrated Systems [SiS] USB 1.0 Controller"
vendorId: 1039
deviceId: 7001
subVendorId: 1039
subDeviceId: 7001
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  1
pcifn:  2
-
class: IDE
class: USB
bus: PCI
detached: 0
driver: ohci-hcd
desc: "Silicon Integrated Systems [SiS] USB 1.0 Controller"
vendorId: 1039
deviceId: 7001
subVendorId: 1039
subDeviceId: 7000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  1
pcifn:  3
-
class: USB
bus: PCI
detached: 0
driver: ohci-hcd
desc: "Silicon Integrated Systems [SiS] USB 1.0 Controller"
vendorId: 1039
deviceId: 7001
subVendorId: 1039
subDeviceId: 7001
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  1
pcifn:  2
-
class: IDE
bus: PCI
detached: 0
desc: "Silicon Integrated Systems [SiS] 5513 [IDE]"
vendorId: 1039
deviceId: 5513
subVendorId: 1039
subDeviceId: 5513
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  0
pcifn:  1
Comment 23 Bill Nottingham 2006-08-24 18:48:14 EDT
Fixed in 1.2.41-1 by removing the offending code - it's no longer needed.

Note You need to log in before you can comment on or make changes to this bug.