Bug 186553 - yum not honoring groupreq in comps files
yum not honoring groupreq in comps files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 06:40 EST by Paul Howarth
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-24 10:46:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2006-03-24 06:40:25 EST
I'm trying to use mock in FC5. It doesn't appear to be installing the
buildsys-macros package, hence the dist tag gets omitted from the built packages.

I made my own copy of the groups repo at
http://fedoraproject.org/buildgroups/4/i386/ and tried to debug it. It appears
to me that yum is no longer honouring <groupreq> clauses in the buildroots.xml
file, as the "yum groupinstall build" done by mock only pulls in the "build"
group itself and not the "build-base" and "build-minimal" groups that it's
supposed to require. Most of the packages in those groups get pulled in as
package dependencies anyway, but that doesn't catch buildsys-macros.

If I add buildsys-macros to the "build" group itself, the package is installed
and all is well.

All references to "groupreq" seem to have disappeared from comps.py in FC5's yum... 

Version-Release number of selected component (if applicable):
yum-2.6.0-1

How reproducible:
Every time

Steps to Reproduce:
1. Install FC5, plus mock from extras.
2. Try to build a package in mock that uses the %{?dist} tag from buildsys-macros
  
Actual results:
Built package does not have %{?dist} tag expanded.

Expected results:
Built package does have %{?dist} tag expanded.

Additional info:
I tried raising this on fedora-extras-list twice but the list appears to be
foobarred due to mail server issues within redhat.
Comment 1 Jeremy Katz 2006-03-24 10:46:47 EST
The comps file format has changed as of FC5 and groupreqs are no longer valid --
they basically caused any user interface to be impossible to actually work.
Comment 2 Paul Howarth 2006-03-24 11:04:11 EST
(In reply to comment #1)
> The comps file format has changed as of FC5 and groupreqs are no longer valid --
> they basically caused any user interface to be impossible to actually work.

OK, thanks for that. The buildgroups files under
http://fedoraproject.org/buildgroups/ are going to need changing to not use
groupreqs then. Should that be a bug on infrastructure or on mock (since mock
includes these buildgroups in the default config files)?

Note You need to log in before you can comment on or make changes to this bug.