Bug 186556 - Can't read files from a samba share
Can't read files from a samba share
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 07:22 EST by Simon Andrews
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-26 08:33:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Andrews 2006-03-24 07:22:30 EST
Description of problem:
When browsing files on a samba share via nautilus I get an error if I try to
read any of the files, although they are listed correctly


Version-Release number of selected component (if applicable):
samba-3.0.21b-2

How reproducible:
Always


Steps to Reproduce:
1. Browse to a samba share via nautilus
2. Perform any operation which requires the file to be read
3.
  
Actual results:
An error message is produced.  The exact error varies depening on the action. 
If I copy a file with nautilus I get:

Error "Not a directory" while copying smb://bi-ne...FILENAME.jpg

If I try to open an image in Gimp I get:

Could not open '/home/andrewss/smb://bi-netapp1a/andrewss/DSCF0103.jppg for
reading: No such file or directory

Expected results:
Files should be read correctly.

Additional info:
All browsing operations work OK.  I am working on a protected share and am
correcly prompted for authentication.  I can see all files as expected and I can
even view their properties correctly, it's only when I try to open them that
things fail.

The samba shares are mounted from a netapp file server (if that matters)

I've opened up the samba ports using system-config-securitylevel.  The
ip_contrack_netbios_ns iptables module is loaded.

There are no messages at all in /var/log/samba/ and nothing relevant in
/var/log/messages
Comment 1 Simo Sorce 2007-03-23 17:49:26 EDT
This: /home/andrewss/smb://bi-netapp1a/andrewss/DSCF0103.jppg is not a valid
path name. Seems to be a nautilus error, Nautilus need to mount the share using
smbfs/cifs vfs to let normal applications read files, or copy the file locally.

Not a samba bug.
Comment 2 Alexander Larsson 2007-03-26 04:19:49 EDT
Not all applications support gnome-vfs which is used to read stuff over samba
(e.g. gimp).
However, you should be able to copy the file to locally with nautilus, can you
describe what you do in that error case in more detail.
Comment 3 Simon Andrews 2007-03-26 04:45:59 EDT
To be honest I'd forgotten about this bug submission it was that long ago.

I just checked on a fully updated system and it seems that something between
last March and now has fixed it.  It all worked fine on the shares on which it
used to fail.

Please feel free to close it.

Cheers

Simon.
Comment 4 Matthias Clasen 2007-03-26 08:33:37 EDT
Thanks, closing then.

Note You need to log in before you can comment on or make changes to this bug.