Bug 18657 - backspace key becomes equivalent to delete key
Summary: backspace key becomes equivalent to delete key
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-08 20:56 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-17 09:32:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-08 20:56:09 UTC
In my fresh install of redhat 7.0, the backspace key is equivalent to the 
delete key.  To do a real backspace, I have to use a ctrl-h combination.  
I checked www.deja.com, and many people are having this problem.  Please 
fix this fast.

Comment 1 Tim Waugh 2000-10-09 11:14:53 UTC
Where does the link /etc/X11/X point?  If it points to a file with a name that
starts 'XF86_', please see if you can find a line in /etc/X11/XF86Config that
says:

	XkbVariant ""

and take/comment that out.  Does that help?

Comment 2 Need Real Name 2000-10-10 03:23:11 UTC
That got it!

My /etc/X11/X link points to ../../usr/X11R6/bin/XF86_mach64.

My XF86Config had a line in it:

XkbVariant "nodeadkeys"

Commenting it out fixed the problem.  I'll post the fix on usenet.

Thanks a lot!

Comment 3 Ronald Cole 2000-10-16 22:19:24 UTC
This happened to be because I followed the directions during install where it
said to disable dead keys if I wasn't going to be entering special characters. 
Well, I only use American English and
didn't see the need to enter those special characters so I disabled the dead
keys.  Big mistake!!
FYI

Comment 4 Need Real Name 2000-10-17 05:05:11 UTC
Yep.  Same here.  Definitely a big problem that should be fixed ASAP.

Comment 5 scheck 2000-10-19 15:15:11 UTC
I've chosen German / Dead keys active with graphical installation:
=> X: del = backspace
=> Xterm: del, backspace = ~
=> no ~, \ and | (keys with Alt Gr)

I commented out these settings
     #XkbRules    "xfree86"
     #XkbModel    "pc104"
     #XkbLayout   "de"
     #XkbVariant  ""
     #XkbOptions  ""
and inserted my old RedHat 6.2 settings
     XkbKeycodes     "xfree86"
     XkbTypes        "default"
     XkbCompat       "default"
     XkbSymbols      "us(pc101)"
     XkbGeometry     "pc"
     XkbRules        "xfree86"
     XkbModel        "pc101"
     XkbLayout       "de"

The only remaining problem was del=backspace in xterm/konsole because of
the missing execution of inputrc. I added -ls (login shell) to konsole parameters
and everything worked fine.



Comment 6 scheck 2000-10-24 07:39:43 UTC
> The only remaining problem was del=backspace in xterm/konsole 
> because of the missing execution of inputrc. I added -ls 
> (login shell) to konsole parameters and everything worked fine.

..except for a konsole opened with Ctrl-T out of kfm, some key 
bindings etc... Sh*t!

What's wrong with the xterm in Red Hat 7?
Where so I have to tweak to get the same behaviour as in RH6.2?


Comment 7 Eli Barzilay 2001-08-17 09:32:45 UTC
I have encountered a similar problem and saw that what caused it is that
XF86Config-4 had the nodeadkeys line, but the X log said that this is an
invalid option.


Comment 8 Mike A. Harris 2001-11-01 03:22:42 UTC
The backspace and delete keys work fine in all applications I've
used in 7.1/7.2 releases.  Closing bug CURRENTRELEASE as I am
not able to reproduce any problems in our current release.  If
there is still a problem in Red Hat Linux 7.2, feel free to
reopen the report and provide updated detailed information.


Note You need to log in before you can comment on or make changes to this bug.