Bug 186577 - libbind.pc bug and package cleanups
Summary: libbind.pc bug and package cleanups
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-24 15:16 UTC by kloczek
Modified: 2013-04-30 23:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-30 10:03:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libbind.pc patch (482 bytes, patch)
2006-03-24 15:16 UTC, kloczek
no flags Details | Diff
named.init patch (10.88 KB, patch)
2006-03-24 15:17 UTC, kloczek
no flags Details | Diff

Description kloczek 2006-03-24 15:16:22 UTC
From emain sesnded to fedora-devel@ list:

I found next bug in current bind. Iin libbind.pc in Libs: is
specyfied -L/usr/lib - this will break 64bit archs
Patch in attachment.

I second atachemnt is patch for init scrips (use tabs instead spaces,
removed trailing spaces and tabs, removed ";" on EOF; rolled in multipe
rm commands to single run with more than one file for remove).

In next attachment are bind.spec cleanups:
- removed trailig spaces and tabs,
- use tabs instead spaces,
- remove gcc and tar from BuildRequires (this is esential BR so specify
  this directly isn't neccessary),
- simplified BuildRequires rules,
- s/textutils, fileutils/coreutils/ in Requires rules,
- removed not neccessatry specs conditions (%if in packages descriptions
  and %post/%postun scripts can be ommited),
- simplifications in %build,
- s/\${RPM_BUILD_ROOT}/$RPM_BUILD_ROOT/
- %clean moved after %install and before all %post/%pre/%post/%postun
  scripts,
- s,/usr/share,%{_datadir},
- cleanups in %prep,
- move unpack RFC docs to %prep (fixes for --short-circuit build),
- remove nit neccessary ";" in scripts and 
- rewrited sdb %postun for use only sed (this allow minimize number of
  Requires it will be also good rewrite %post script in sed because
  using this allow remove from sdb Requires(post) mktemp and SELinux
  utils because sed preserves SElinux context on files).

Comment 1 kloczek 2006-03-24 15:16:22 UTC
Created attachment 126632 [details]
libbind.pc patch

Comment 2 kloczek 2006-03-24 15:17:50 UTC
Created attachment 126633 [details]
named.init patch

Comment 3 Jason Vas Dias 2006-03-24 18:24:59 UTC
Thank you -
Some of your .spec file suggestions seem sensible and will be incorporated
in the next bind-9.3.2-14_FC{6,5} releases.

I think it is just silly to submit patches containing whitespace only changes -
'patch -l' ignores them anyway, and they just obscure the other changes you
suggest - please omit whitespace only changes from any future patches -
(use diff -bB) - thanks.

Regards,
Jason.

Comment 4 Jason Vas Dias 2006-03-30 01:16:06 UTC
This bug is now fixed, with bind-9.3.2-14.FC{5,6} . 
libbind.pc no longer specifies "Libs: -L/usr/lib -lbind", and most of the 
issues raised in your bind.spec patch (which I found on fedora-devel) have
been addressed.
bind-9.3.2-14.FC5 is now being submitted to FC-5 Updates/Testing .


Comment 5 Fedora Update System 2006-03-30 21:22:45 UTC
bind-9.3.2-14.FC5 has been pushed for FC5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 6 Fedora Update System 2006-04-17 15:43:47 UTC
bind-9.3.2-16.FC5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 7 Adam Tkac 2007-05-30 10:03:45 UTC
Looks like fixed. If still exists, please reopen.

Regards, Adam


Note You need to log in before you can comment on or make changes to this bug.