Bug 186578 - Dual Head Problems with nVidia
Dual Head Problems with nVidia
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 10:19 EST by daleville
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 16:30:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (72.39 KB, text/plain)
2006-03-24 10:19 EST, daleville
no flags Details
xorg.conf (2.48 KB, text/plain)
2006-03-24 10:23 EST, daleville
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 6381 None None None Never

  None (edit)
Description daleville 2006-03-24 10:19:00 EST
I am unable to use my nVidia RIVA TNT2 Model 64 PCI card in combination with any
other video card that I have tried with X. Whenever attempting to load X with
the aforementioned card alongside any other card results in the display becoming
locked, forcing a reboot. I have tried this card on two systems running FC5 with
the same results. One system I tried the combination of the onboard video and
the PCI nVidia card to no avail (dual head with this exact same setup worked in
FC4). Then I tried the same system with an AGP nVidia card along side the PCI
nVidia card with the same results. 

The machine I currently am using and having the problems with I will detail below.

---------------------------
/sbin/lspci -v

01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400]
(rev b2) (prog-if 00 [VGA])
    Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
    Memory at f4000000 (32-bit, non-prefetchable) [size=16M]
    Memory at e0000000 (32-bit, prefetchable) [size=128M]
    Expansion ROM at f5df0000 [disabled] [size=64K]
    Capabilities: [60] Power Management version 2
    Capabilities: [44] AGP version 2.0

02:09.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model
64/Model 64 Pro] (rev 15) (prog-if 00 [VGA])
    Subsystem: nVidia Corporation Unknown device 0006
    Flags: 66MHz, medium devsel, IRQ 11
    Memory at f6000000 (32-bit, non-prefetchable) [disabled] [size=16M]
    Memory at f0000000 (32-bit, prefetchable) [disabled] [size=32M]
    Expansion ROM at efc20000 [disabled] [size=64K]
    Capabilities: [60] Power Management version 1

---------------------------
Xorg -scanpci

(1:0:0) nVidia Corporation NV11 [GeForce2 MX/MX 400]
(2:9:0) unknown card (0x10de/0x0006) using a nVidia Corporation NV5M64 [RIVA
TNT2 Model 64/Model 64 Pro]
---------------------------

I have attached the resulting Xorg.0.log.

Finally the PCI nVidia card will successfully run X when it is the only card in
the system.
Comment 1 daleville 2006-03-24 10:19:01 EST
Created attachment 126634 [details]
xorg log file
Comment 2 daleville 2006-03-24 10:23:43 EST
Created attachment 126635 [details]
xorg.conf

Here's the xorg.conf I am using with the described configuration.
Comment 3 Mike A. Harris 2006-03-24 15:58:24 EST
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.



Note You need to log in before you can comment on or make changes to this bug.