Bug 186581 - CLARiiON LUNZ issue with multipath tools
CLARiiON LUNZ issue with multipath tools
Status: CLOSED DUPLICATE of bug 174441
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 10:48 EST by Hari Kannan
Modified: 2010-01-11 21:24 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-24 12:17:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hari Kannan 2006-03-24 10:48:56 EST
Description of problem:
When a CLARiiON LUNZ is exposed then the system hangs on reboot. 

Version-Release number of selected component (if applicable):
RHEL 4 U3.

How reproducible:
Everytime.

Steps to Reproduce:
1. Configure a RHEL- 4  U3 host for MPIO.
2. Connect to a clariion array with proper zoning. Do not add any devices to the
storage group.
3. Reboot the host.
  
Actual results:
The system hangs on reboot

Expected results:
The system should boot up fine.


Fix: 

The code to fix this issue is already included in the latest multipath kit
upstream.  The code changes are restricted to the multipath-tools package in
user space.  The code changes allow the blacklisting of target block devices
based on particular combinations of "vendor" and "product" attribute string
values by specifying newly supported vendor and product blacklist directives in
either the multipath.conf file or the default blacklisting via the hwentry
structures defined in libmultipath/hwtable.c  The CLARiiON hwentry entry in
hwtable.c establishes a blacklist entry for the vendor string "DGC" and the
product string "LUNZ".

Request to include this as part of RHEL 4 U4.
Comment 1 Alasdair Kergon 2006-03-24 12:17:41 EST

*** This bug has been marked as a duplicate of 174441 ***

Note You need to log in before you can comment on or make changes to this bug.