This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 186586 - radeon display garbled and unusable
radeon display garbled and unusable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 11:02 EST by Jason Vas Dias
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-05 13:37:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'X -probeonly' log created by driver causing garbled display (32.39 KB, text/plain)
2006-03-24 11:03 EST, Jason Vas Dias
no flags Details
'X -probeonly' log from driver creating OK display (31.47 KB, text/plain)
2006-03-24 11:05 EST, Jason Vas Dias
no flags Details
xorg.conf (2.92 KB, text/plain)
2006-03-24 11:07 EST, Jason Vas Dias
no flags Details
'startx' log from xorg-x11-drv-ati-6.5.7.3-4.cvs20060322 causing garbled display (44.16 KB, text/plain)
2006-03-24 18:41 EST, Jason Vas Dias
no flags Details
'startx' log after downgrading to xorg-x11-drv-ati-6.5.7.3-4 with OK display (40.58 KB, text/plain)
2006-03-24 18:44 EST, Jason Vas Dias
no flags Details

  None (edit)
Description Jason Vas Dias 2006-03-24 11:02:03 EST
Description of problem:

After upgrade to xorg-x11-drv-ati-6.5.7.3-4.cvs20060322.i386.rpm on 
an IBM T41 laptop with a Radeon display card, as reported in lspci:
  01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW
[Radeon Mobility 7500]
the display was completely garbled / unreadable .

Downgrading to xorg-x11-drv-ati-6.5.7.3-4.i386 and restarting X fixed the
problem, with the same xorg-x11-server-Xorg-1.0.99.1-2 server.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.5.7.3-4.cvs20060322.i386.rpm

How reproducible:
100%

Steps to Reproduce:
start X
  
Actual results:
unusable garbled display

Expected results:
usable display

Additional info:
I'm attaching the X -probeonly logs
A) From the driver causing the garbled display:
   Xorg.0.log-drv-ati-6.5.7.3-4.cvs20060322
B) From the driver providing the usable display:
   Xorg.0.log-drv-ati-6.5.7.3-4
and my xorg.conf file.
Comment 1 Jason Vas Dias 2006-03-24 11:03:49 EST
Created attachment 126640 [details]
'X -probeonly' log created by driver causing garbled display
Comment 2 Jason Vas Dias 2006-03-24 11:05:11 EST
Created attachment 126641 [details]
'X -probeonly' log from driver creating OK display
Comment 3 Jason Vas Dias 2006-03-24 11:07:22 EST
Created attachment 126642 [details]
xorg.conf
Comment 5 Jason Vas Dias 2006-03-24 11:47:16 EST
Problem still happens with kernel-2.6.16-1.2088_FC6 .
Comment 6 Mike A. Harris 2006-03-24 18:16:07 EST
startx normally with the problematic server, and attach the log from that
please.
Comment 7 Jason Vas Dias 2006-03-24 18:41:43 EST
Created attachment 126678 [details]
'startx' log from xorg-x11-drv-ati-6.5.7.3-4.cvs20060322 causing garbled display
Comment 8 Jason Vas Dias 2006-03-24 18:44:05 EST
Created attachment 126679 [details]
'startx' log after downgrading to xorg-x11-drv-ati-6.5.7.3-4 with OK display
Comment 9 Jason Vas Dias 2006-03-24 18:49:47 EST
Clarification of "Garbled":
With xorg-x11-drv-ati-6.5.7.3-4.cvs20060322, the display is initially clear 
and the 'X' cursor shows OK until the first image is displayed (ie. the KDE/GNOME
splash screen). Then it looks like every image is repeated horizontally across
the screen at horizontal increments of around 10 pixels - this is repeated for
every icon shown when the desktop appears.

Comment 10 Jason Vas Dias 2006-04-05 13:37:06 EDT
This bug is now fixed with xorg-x11-drv-ati-6.5.7.3-4.cvs20060404 - thanks !

Note You need to log in before you can comment on or make changes to this bug.