Bug 186608 - Failed to update package
Failed to update package
Status: CLOSED DUPLICATE of bug 186227
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 12:38 EST by Granville Xiong
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-26 04:02:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Granville Xiong 2006-03-24 12:38:31 EST
Description of problem:

yumex failed to udpate some selected packages from Fedora Core 5 update
repository. However using the command line like "yum update <packages>" succeeded!

Version-Release number of selected component (if applicable):

0.99.14-1.0.fc5

How reproducible:

Everytime

Steps to Reproduce:
1. Launch yumex.
2. Do the update.
3. Some package updates will fail while the command line tool "yum" always succeeds.
  
Actual results:

Update failed, and the worst thing is that, for example, when yumex failed to
update the original xorg-x11-server-Xorg to the updated version
xorg-x11-server-Xorg-1.0.1-8.i386.rpm, the original package was removed but the
new package has not been installed. This left my system without
xorg-x11-server-Xorg! Too bad!

Expected results:

Update through yumex should work because the packages themsevles are totally fine.

Additional info:

See the screen output below:
error: %pre(bind-9.3.2-12.FC5.i386) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping bind-9.3.2-12.FC5
error: %pre(avahi-0.6.9-8.FC5.i386) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping avahi-0.6.9-8.FC5
error: %post(curl-7.15.1-3.i386) scriptlet failed, exit status 255
error: %pre(sendmail-8.13.6-0.FC5.1.i386) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping sendmail-8.13.6-0.FC5.1
error: %pre(beagle-0.2.3-4.i386) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping beagle-0.2.3-4
error: %pre(xorg-x11-server-Xorg-1.0.1-9.i386) scriptlet failed, exit status
255error:   install: %pre scriptlet failed (2), skipping
xorg-x11-server-Xorg-1.0.1-9
error: %post(tcsh-6.14-6.fc5.1.i386) scriptlet failed, exit status 255
Comment 1 Tim Lauridsen 2006-03-25 13:20:20 EST
There is a problem with yumex & SELinux= Enforcing

Read more here.

http://linux.rasmil.dk/cms/modules/news/article.php?storyid=51
Comment 2 Tim Lauridsen 2006-03-26 04:02:01 EST

*** This bug has been marked as a duplicate of 186227 ***

Note You need to log in before you can comment on or make changes to this bug.