This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 186611 - api_pipe_bind_req: unknown auth type 1 requested
api_pipe_bind_req: unknown auth type 1 requested
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Guenther Deschner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 12:52 EST by Matthew Crawford
Modified: 2010-04-19 10:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-19 10:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Crawford 2006-03-24 12:52:57 EST
Description of problem:

When a windows 2003 server with SP1 installs accesses a samba share it returns the following error into 
the log:

Mar 24 12:45:52 atlsvrnas01 smbd[2648]: [2006/03/24 12:45:52, 0] rpc_server/
srv_pipe.c:api_pipe_bind_req(993) 
Mar 24 12:45:52 atlsvrnas01 smbd[2648]:   api_pipe_bind_req: unknown auth type 1 requested. 

Version-Release number of selected component (if applicable):

RHE 4
samba-common-3.0.10-1.4E.6
system-config-samba-1.2.21-1
samba-client-3.0.10-1.4E.6
samba-3.0.10-1.4E.6

How reproducible:

Every time

Steps to Reproduce:
1. Set up samba / winbind / ads
2. Create file share
3. Have windows 2003 sp1 client connect to it.
  
Actual results:

The above error in the samba logs.

Expected results:

No such error.

Additional info:

This has been reported as fixed in the Samba groups with version 3.0.14a and above. Looks like 
package just needs to be update to more current versions to correct this problem for everyone.
Comment 2 Johnny Hughes 2006-12-14 08:25:25 EST
I am not sure if this is the problem exactly or not, however users on a Win 2003
Server connected to the current version of Samba can not change their domain
password in my setup.

That error (api_pipe_bind_req: unknown auth type 1 requested) shows up in the
logs when they try to change the password and the domain is reported as not
available.

I am currently testing the samba-3.0.23d-30 from:

 http://www.enterprisesamba.org/

I have moved my ldap database and samba configs over to a test environment and I
can change my password from a win 2003 server in that test environment.

Note You need to log in before you can comment on or make changes to this bug.