Bug 186638 - kickstart nfs installation fails
Summary: kickstart nfs installation fails
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-24 21:43 UTC by jmccann
Modified: 2015-01-14 23:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 18:53:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jmccann 2006-03-24 21:43:13 UTC
A NFS installation of FC5 using kickstart fails.  It doesn't seem to be related
to the ks.cfg since I've tried ones from FC4 and newly generated ones using
system-config-kickstart.  I've verified all md5sums on media that were loaded
onto the NFS drive.

An error dialog says:
Unable to read package metadata.  This may be due to a missing repodata
directory.  Please ensure that your [snip]


I've even tried using createrepo in the RPMS directory but that didn't seem to
matter.

Comment 1 Jeremy Katz 2006-03-27 18:12:34 UTC
How did you create your repository?

Comment 2 jmccann 2006-03-27 18:15:11 UTC
Just copied the Fedora directory from the DVD.  This is what I usually do.  Is
there another step now?

Comment 3 Paul Nasrat 2006-03-27 18:41:41 UTC
Did you copy the repodata dir too?  The readme needs to be updated, you need
Fedora and repodata parallel to it.

Comment 4 jmccann 2006-03-27 18:53:09 UTC
Thanks Paul!  That was it.  Sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.