Bug 186661 - FC4 to FC5: nisplus in hosts line for /etc/nsswitch.conf breaks wget, yum, and rpm
FC4 to FC5: nisplus in hosts line for /etc/nsswitch.conf breaks wget, yum, an...
Status: CLOSED DUPLICATE of bug 186592
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 23:48 EST by Mike Moore
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 14:26:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade log from FC4 to FC5 (23.47 KB, text/plain)
2006-03-27 18:16 EST, Mike Moore
no flags Details

  None (edit)
Description Mike Moore 2006-03-24 23:48:27 EST
Description of problem:
Upgraded box from FC4 to FC5 using CDs. After FC5 is installed wget, yum, and
rpm http all fail, claiming no such file or directory. curl, lynx, and good ol'
telnet on port 80 properly retrieve files from webservers.

The upgrade leaves /etc/nsswitch.conf w/ the following hosts config:
hosts: files nisplus dns

removing nisplus fixes the problems with wget, yum and rpm http. Another FC5 box
I have access to (formatted and installed clean) has the hosts config as only
files and dns. The FC4 box worked properly before the upgrade.

Version-Release number of selected component (if applicable):
FC5 initial release upgrades from fully patched FC4 box

How reproducible:
Add nisplus back into the config and it is broken. Even with nscd running.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
wget yum and rpm http fail to download files

Expected results:
wget yum and rpm http should download files

Additional info:
Another user in #fedora on freenode had the exact same issue with the same
resolution. Will be directing him to add to this bug report.
Comment 1 Jeremy Katz 2006-03-27 13:45:00 EST
Had you set up things to use nisplus?  We never ship with that as the config. 
Can you provide the /root/upgrade.log?
Comment 2 Mike Moore 2006-03-27 18:16:13 EST
Created attachment 126862 [details]
upgrade log from FC4 to FC5

Upgrade log
Comment 3 Mike Moore 2006-03-27 18:20:07 EST
No, I don't know what nisplus is; I just layed FC5 over FC4; I've taken this box
from FC1 and some older RH boxes through each FC release, but this was the first
time I had any issues with it.

Thanks,
Comment 4 Jeremy Katz 2006-03-28 14:26:33 EST
Caused by nisplus being broken in glibc :-/

*** This bug has been marked as a duplicate of 186592 ***
Comment 5 Chris Walter 2006-03-29 10:23:20 EST
I had the same problem on FC4 after the recent update to glibc-2.3.6-3

Note You need to log in before you can comment on or make changes to this bug.