Bug 186667 - X fails to start with GLX module loaded
X fails to start with GLX module loaded
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 02:28 EST by Richard Tresidder
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 20:12:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log of failed startup (37.94 KB, text/plain)
2006-03-25 02:48 EST, Richard Tresidder
no flags Details

  None (edit)
Description Richard Tresidder 2006-03-25 02:28:16 EST
Description of problem:
I have just done an update of FC5 Test3 via pup to what was in the default
repository (that is set from installation) to what was available as of today
(25th March 2006). This however seems to have come with a bug, X will no longer
start up with the GLX extension loaded, it seems to simply hang and the only
thing that will respond is a ctrl+alt+delete, can't switch VT's to see whats
happening etc.
I have a Dell Inspiron 9300 laptop with an ATI Raedon X300 card.

Not sure if the repository that these updates came from is a development for
next FC6 (kernel seems to be tagged as such) or if it is the latest available
for FC5 in effect.

X log file does not contain any info beyond the Initializing built-in extension
XEVIE on a failed startup.

messages shows no indication of a problem, except after hitting ctrl+alt+del and
then gets info about X startup failure..

will post logs in sec

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce: Maybe Graphic card / driver specific
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard Tresidder 2006-03-25 02:48:47 EST
Created attachment 126703 [details]
xorg log of failed startup
Comment 2 Richard Tresidder 2006-03-25 02:49:50 EST
/var/log/messages shows no information pertaining to X
Comment 3 Mike A. Harris 2006-05-18 20:12:13 EDT
(In reply to comment #0)
> Description of problem:
> I have just done an update of FC5 Test3 via pup to what was in the default
> repository (that is set from installation) to what was available as of today
> (25th March 2006). This however seems to have come with a bug, X will no longer
> start up with the GLX extension loaded, it seems to simply hang and the only
> thing that will respond is a ctrl+alt+delete, can't switch VT's to see whats
> happening etc.
> I have a Dell Inspiron 9300 laptop with an ATI Raedon X300 card.
> 
> Not sure if the repository that these updates came from is a development for
> next FC6 (kernel seems to be tagged as such) or if it is the latest available
> for FC5 in effect.

Without having a concrete idea of what specifically you are running, it
is difficult at best to try to diagnose or reproduce such a problem.
The problem could potentially even be caused by using rawhide packages
with FC5 packages which are not compatible with each other.

Please do a clean OS install of FC5 and update it with yum to the current
released FC5 updates.  If the problem still occurs, reopen the bug report
and attach an X server log file and config file from the clean FC5 OS
install from the problematic invocation and we'll review the new details.

Note You need to log in before you can comment on or make changes to this bug.