Bug 186670 - eAccelerator 0.9.4
Summary: eAccelerator 0.9.4
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: php-eaccelerator   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-25 07:42 UTC by Bart Vanbrabant
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 5.0.1_0.9.4-1.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 10:33:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bart Vanbrabant 2006-03-25 07:42:11 UTC
eAccelerator 0.9.4 has been released about a month ago. This is mainly a bugfix
release.

Comment 1 Matthias Saou 2006-04-07 13:36:20 UTC
Do you know if any of the x86_64 specific locking issues are fixed? Or have
those been identified as being arch specific problems that have nothing to do
with eA itself?

Comment 2 Bart Vanbrabant 2006-04-09 10:58:20 UTC
I think most of these problems have been fixed. There were two things causing
these problems:

1) spinlocks were never picked because they would only be enabled on x86 and not
x86_64. These will be selected now and they work fine.
2) After spinlocks sysvipc semaphores were selected but there was a error in the
implementation. The owner was root and they weren't publicly writeable, so the
apache children couldn't aquire a lock.

A lot of other bugs are fixed so upgrading would be a good thing.

Comment 3 Matthias Saou 2006-04-11 14:19:59 UTC
OK, I'll be testing 0.9.4 on some of my busy x86_64 servers running 4.4.x then
update the packages if things work ok.

Comment 4 Matthias Saou 2006-04-11 15:51:48 UTC
The default on x86_64 seems to be shm:sysvipc and sem:spinlock, and works fine
for me now... are these the optimal values for Fedora according to you?

Comment 5 Bart Vanbrabant 2006-04-11 15:58:59 UTC
I don't know if they are the fastest but they are used by 99.9% of all eA users
so they've gotten the most testing. Those are the ones I recommend using. That's
also the reason the configure script selects them ;)

Comment 6 Matthias Saou 2006-05-10 10:33:14 UTC
I've rebuilt this package at last. I had been waiting to get the development
package of 0.9.5beta2 out first, but since I'm out of luck with a broken Rawhide
tree each time I try, I've decided to push this package anyway.

Thanks for all your advice!


Note You need to log in before you can comment on or make changes to this bug.