Bug 186690 - dbx database function support missing in php php-5.1.2
dbx database function support missing in php php-5.1.2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 186691 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 08:15 EST by rambler8
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-25 10:06:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rambler8 2006-03-25 08:15:20 EST
The dbx database functions were removed from the PHP 5.1.0 base
See: http://www.php.net/DBX

The are now maintained as a PECL extenstion
Source is avialable from:
http://pecl.php.net/package-changelog.php?package=dbx

I use these functions to allow easy flebility to switch databases without having
to change code except for the intial connection string. 

Please add dbx extentions to the php rpm or make them available in a seperate rpm
Comment 1 Joe Orton 2006-03-25 09:56:17 EST
*** Bug 186691 has been marked as a duplicate of this bug. ***
Comment 2 Joe Orton 2006-03-25 10:06:17 EST
This would be welcomed as a contribution to Extras.
Comment 3 rambler8 2006-03-25 11:46:09 EST
Considering that it breaks backwards compatability and will likely be included 
in the next RHEL release, I feel that its important that it be included in the 
main tree.

Note You need to log in before you can comment on or make changes to this bug.