Bug 186709 - byzanz causes Nautilus to use 86% memory
byzanz causes Nautilus to use 86% memory
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: byzanz (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 10:29 EST by jim
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-25 16:30:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jim 2006-03-25 10:29:49 EST
Description of problem:
byzanz causes Nautilus to use 86% memory

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.yum install byzanz 
2.add desktop recorder to the Gnome Panel
3. record your desktop 
4. 
  
Actual results:
System becomes unresponsive. Cpu usage ramps to near 100%  Nautilus process
consumes 86% of memory.  trying to open a terminal windows becomes a task in
it's self.  Once the terminal was open running top shouws nautilus consuming
most of the system memory 

Expected results:
The oppisite of the actual results

Additional info: 
System has 768 MB of memory  after running the application i had only 6800 kb's
of memory for any other application.  Only way to cure the problem is to hit
CNTL ALT Backspace to kill gnome open the failsafe terminal and yum remove byzana
Comment 1 Jeffrey C. Ollie 2006-03-25 16:30:03 EST
This is probably due to the inefficency of the GIF library that Nautilus uses. 
Since most GIFs tend to be relatively small (even animated GIFs) GIF libraries
load the entire GIF into memory.  If the GIF is animated it will decode the
entire GIF and create a buffer for every frame.  Byzanz can create extremely
large animated GIFs, especially if you are recording the entire desktop. 
Nautilus is probably trying to open the GIF to create a thumbnail.  Try saving
the GIF in a directory that Nautilus doesn't monitor for changes (/tmp or
/var/tmp maybe).

Note You need to log in before you can comment on or make changes to this bug.