Bug 186727 - gnome-cd eject CD Button does not close tray
Summary: gnome-cd eject CD Button does not close tray
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-25 19:23 UTC by Brad Smith
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 10:18:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brad Smith 2006-03-25 19:23:03 UTC
Description of problem:
After listening to a music CD with gnome-cd i would like to eject the cd and
replace it. Eject works fine. But clicking the same button to close the tray
does not work. This worked fine in FC4 on the same hardware.


Version-Release number of selected component (if applicable):
gnome-media-2.14.0-2.x86_64

How reproducible:
Every time.



Steps to Reproduce:
1. play cd with gnome-cd
2. click eject-cd
3. click eject-cd to close tray
  
Actual results:
cd tray does not close.



Expected results:
cd tray to close.

Additional info:
when i close the tray manually on the hardware, a new instance of gnome-cd is
launched. this is irritating.

Comment 1 Bastien Nocera 2007-04-17 13:25:23 UTC
(In reply to comment #0)
> Description of problem:
> After listening to a music CD with gnome-cd i would like to eject the cd and
> replace it. Eject works fine. But clicking the same button to close the tray
> does not work. This worked fine in FC4 on the same hardware.

Do you still see the same problem in FC6? (I don't have any hardware where the
closing of the device is motorised).

> Additional info:
> when i close the tray manually on the hardware, a new instance of gnome-cd is
> launched. this is irritating.

Make sure you have "gnome-cd --unique --play --device %d" as the command to
launch when inserting audio CDs in the removable discs preferences.


Comment 2 Brad Smith 2007-04-17 22:05:56 UTC
Thanks for the query for more information.  I still see the problem with tray
closing in FC 6.  Thank you for the gnome-cd command string above.  That solved
the problem with multiple instances of gnome-cd being created.

Brad Smith

Comment 3 Bastien Nocera 2007-04-19 14:12:08 UTC
The code to close the tray is disabled in the code, no idea why:
#if 0
  gnomecdrom_class->close_tray = gst_cdrom_close_tray;
#endif

Reported upstream at:
http://bugzilla.gnome.org/show_bug.cgi?id=431361

Comment 4 Bastien Nocera 2007-05-01 10:18:14 UTC
That code looks like it's completely busted. I'm leaving it up to upstream to
sort out, my attempts were far from successful, and the code base is horrible.


Note You need to log in before you can comment on or make changes to this bug.