Bug 186728 - ERROR DURING SOFTWARE UPDATER IN FC5
ERROR DURING SOFTWARE UPDATER IN FC5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: p6spy (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wringe
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 14:31 EST by AHMED_AM
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 09:07:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Component: Software Updater - TypeError: rpmdb open failed Summary: TBc7d02ae3 config.py:689:_getsysver:TypeError: rpmdb open failed (1.04 KB, text/plain)
2006-11-15 22:01 EST, Charles Ferguson
no flags Details

  None (edit)
Description AHMED_AM 2006-03-25 14:31:42 EST
Component: Software Updater
Summary: TBa02cbfcc repos.py:629:get:RepoError: failure: repodata/primary.xml.gz
from extras: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 382, in ?
    main()
  File "/usr/sbin/pup", line 378, in main
    pup.run()
  File "/usr/sbin/pup", line 353, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 161, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 151, in reposSetup
    self.doSackSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 291, in doSackSetup
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 287, in populateSack
    xml = repo.getPrimaryXML()
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 796, in getPrimaryXML
    return self._retrieveMD('primary')
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 783, in _retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 629, in get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
RepoError: failure: repodata/primary.xml.gz from extras: [Errno 256] No more
mirrors to try.

Local variables in innermost frame:
e: [Errno 256] No more mirrors to try.
prxy: None
url: None
text: None
self: extras
cache: True
reget: None
relative: repodata/primary.xml.gz
headers: None
checkfunc: (<bound method Repository._checkMD of <yum.repos.Repository instance
at 0xb797ff8c>>, ('primary',), {})
copy_local: 1
end: None
local: //var/cache/yum/extras/primary.xml.gz
start: None
Comment 1 Charles Ferguson 2006-11-15 22:01:07 EST
Created attachment 141337 [details]
Component: Software Updater - TypeError: rpmdb open failed
Summary: TBc7d02ae3 config.py:689:_getsysver:TypeError: rpmdb open failed
Comment 2 Matt Wringe 2007-04-26 09:07:03 EDT
Not a bug with p6spy, please open a bug with the proper component.
This looks to be an issue with your rpm, pup or yum setup, most likely just a
configuration issue done by the user.

Note You need to log in before you can comment on or make changes to this bug.