Bug 186745 - pirute does not recalculate dependencies once there is a failure. Lack of some key usability features makes this a problem.
pirute does not recalculate dependencies once there is a failure. Lack of so...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 20:43 EST by Greg Morgan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 14:16:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First error message from pirut. (1.94 KB, text/plain)
2006-03-25 20:50 EST, Greg Morgan
no flags Details
next (1.46 KB, text/plain)
2006-03-25 20:52 EST, Greg Morgan
no flags Details
next (554 bytes, text/plain)
2006-03-25 20:53 EST, Greg Morgan
no flags Details
next (555 bytes, text/plain)
2006-03-25 20:53 EST, Greg Morgan
no flags Details
next 4 (1.48 KB, text/plain)
2006-03-25 20:54 EST, Greg Morgan
no flags Details
next 5 (642 bytes, text/plain)
2006-03-25 20:55 EST, Greg Morgan
no flags Details
next 6 (554 bytes, text/plain)
2006-03-25 20:56 EST, Greg Morgan
no flags Details
Number 7 and last (106.92 KB, text/plain)
2006-03-25 20:59 EST, Greg Morgan
no flags Details
I forgot about this file. Must have beent between 0.txt and 1.txt. (2.01 KB, text/plain)
2006-03-25 21:02 EST, Greg Morgan
no flags Details
All packages selected in extras. Slider is too small. If you move slider it looks like you selected five packages. (301.22 KB, image/png)
2006-03-25 21:04 EST, Greg Morgan
no flags Details
Same issue as 126755 but on the error message log after dependancy failure. (294.45 KB, image/png)
2006-03-25 21:05 EST, Greg Morgan
no flags Details
Screen shot showing how I tried to click and unclick to resolve issues in pirut. (232.21 KB, image/png)
2006-03-25 21:07 EST, Greg Morgan
no flags Details

  None (edit)
Description Greg Morgan 2006-03-25 20:43:48 EST
Description of problem:
Yeah Yeah.  I was asking for trouble when I wanted to install all five discs of
FC5 and all the extras too.  LOL.   This has been a great release ya'll.  You
see if the alpha Linux geek says that gnome is for idot's then this wimp gnome
interface must be ready for prime time.  Yeah!...but I digress.  I tried not to
touch the command line when I tried installing all the packages.  Anaconda works
great.  First boot works great.  I used pup for the updates that were available.
 I tried using pirut to install everything in extras several times.  At that
point I had to resort to yum to try and install some packages then go back to
pirut.  What I discovered is that pirute does not recalculate the dependancies
when an error occurs even when the user removes the errant packages.  This
dawned on me the second and third time today when the first calculation takes a
lone time; error; then remove packages; click apply; and same error message
comes back even though the list of packages showed that the packages were removed.

Version-Release number of selected component (if applicable):

There's one problem.  The help about message does not have pirut in the name.  A
person has to send the icon to the panel to find the name of the application. 
This is the first release of pirut on fc5.  rpm -q --whatprovides pirut
pirut-1.0.1-1

How reproducible:

Try and suck done any list from extras that has missing dependancies and press
apply.

Steps to Reproduce:
1. Try and suck done any list from extras that has missing dependancies and
press apply.
2. Remove packages that have this problem.
3. Press apply again.
  
Actual results:

Resort to yum or yumex.

Expected results:

Remove packages and press apply to move past the missing dependancies.

Additional info:

* Key user issue come to light.  If you want to select all the packages, then a
select and deselect button are missing to make this chore easy.  Compare pirut
with yumex,  Note that yumex is missing app name/version in help about too.

* Both yum and yumex provide key visual indicators that progress is being made
while pirut and it's one bar feels like it hangs.  Pup has the same feel to it.

* Once you apply a selection and pirut installs the selected list.  It is a pain
to fire up pirut again when you to bang your head agains the wall and try again.
;-)  Staying in the screen have ok would be a nice plus.

* Thankfully a person can drag the error text out of the display screens.
Perhaps I don't have logging set correctly but it would it be better to log this
stuff in /var/log/yum.conf too?

* There's yumdownloader, pup, pirut, yumex, and yum.  It was nice to know who
installed what in the log file.  Can these other apps follow yumex and put there
name in the log file kind-of link syslog?
Mar 25 14:10:42 (yumex) Installed: torcs-data-cars-Patwo-Design.noarch 1.2.2-1
Mar 25 14:44:00 Installed: perl-XML-NamespaceSupport.noarch 1.09-1.2

* Bonus points are awared if repo meta data is used as noted here
http://blog.sethdot.org/index.cgi/2005/Jun  Googling helped me find the idea to
use repoquery to figure out where the problem libraries were in a couple of
combinations.  yum "seems" to take care of this.  pirut, yumex, and pup could
use the kinds of queries to visually show where the problem package is in the
list.  That would be important on a long list of packages.  Ideas are
history | grep -i repo
   53  repoquery
   81  more repomd.xml
   88  repoquery
   89  repoquery
   90  repoquery --whatrequires python-reportlab
  139  repoquery --whatrequires python-reportlab
  140  repoquery --whatrequires scribus
  141  repoquery --whatrequires scribus-templates
  142  repoquery --whatrequires gambas-devel
  143  repoquery --whatrequires gambas

Additional captain's logs are attached with numbers in their names.  I got
smarter at the end and logged more of the actions.  Key file is number .*7.txt.

Bugs 186082, 186112, and 186082 were consulted but these one is an error report
and two shows all the user problems experienced when the bug occured.

Looking at the glass as 3/4 full: This has been a very nice release.  Theses
items here are a few small issues.
Comment 1 Greg Morgan 2006-03-25 20:48:48 EST
* Oh the error message boxes need to be larger.
* The slider--perhaps a gnome relaease issue--does note scale correctly for a
long list and a small message box.  The user thinks they only have four or five
packages selected in this situation.  Several screen shots are attached too.
Comment 2 Greg Morgan 2006-03-25 20:50:56 EST
Created attachment 126745 [details]
First error message from pirut.

Last file is the most important.
Comment 3 Greg Morgan 2006-03-25 20:52:05 EST
Created attachment 126746 [details]
next

Last file is the most important.
Comment 4 Greg Morgan 2006-03-25 20:53:03 EST
Created attachment 126747 [details]
next

Last file is the most important.
Comment 5 Greg Morgan 2006-03-25 20:53:50 EST
Created attachment 126748 [details]
next

Last file is the most important.
Comment 6 Greg Morgan 2006-03-25 20:54:25 EST
Created attachment 126749 [details]
next 4

Last file is the most important.
Comment 7 Greg Morgan 2006-03-25 20:55:11 EST
Created attachment 126750 [details]
next 5

Last file is the most important.
Comment 8 Greg Morgan 2006-03-25 20:56:05 EST
Created attachment 126751 [details]
next 6

Last file is the most important.
Comment 9 Greg Morgan 2006-03-25 20:59:39 EST
Created attachment 126753 [details]
Number 7 and last

Note later in the file where I would click and unclick the packages with issues
but still receive the same error message.  The key is that I noticed that
subsequent calculations were shorter that then original package list
calculation.  Hence pirut did not use the new list even though the logs in the
screen showed that the packages were not there.
Comment 10 Greg Morgan 2006-03-25 21:02:15 EST
Created attachment 126754 [details]
I forgot about this file.  Must have beent between 0.txt and 1.txt.

Tried to carefully remove all the packages hoping to resolve the problem.  Note
the x's on the left side where I checked off off each package with issues.
Comment 11 Greg Morgan 2006-03-25 21:04:21 EST
Created attachment 126755 [details]
All packages selected in extras.  Slider is too small.  If you move slider it looks like you selected five packages.
Comment 12 Greg Morgan 2006-03-25 21:06:00 EST
Created attachment 126756 [details]
Same issue as 126755 but on the error message log after dependancy failure.
Comment 13 Greg Morgan 2006-03-25 21:07:40 EST
Created attachment 126757 [details]
Screen shot showing how I tried to click and unclick to resolve issues in pirut.
Comment 14 Greg Morgan 2006-03-25 21:11:53 EST
* Final note.  Ok so this time I want to put all the packages on five computers.
 It took a long time to get one done.  Other than regexing the /var/log/yum.conf
is there a way to log the packages selected for later scripting in anaconda.  It
seems like I could note figure out how to use yumdownloader or yum to suck down
the packages I wanted to a local repository.  I am note left with a list that I
can < pipe into yum, et all.  Any ideas on this or is this another enhancement idea?

Greg
Comment 15 Greg Morgan 2006-03-27 00:49:27 EST
Here's another design consideration for pirut and perhaps pup, and yumex.  If I
put Nautilus in view as list mode, then I am able to click, control click, or
shift click items in the list.  Even if you can put a select all, control a, or
deselect all, as buttons, then pirut is still missing the expected click and
shift click a range functionality.  If I want to select all the m17n,
multilingualization, packages, then I have to click and select each one.  That
seems like an important and expected feature of a list has been left out.
Comment 16 Andrea Santilli 2006-03-28 19:10:59 EST
I can confirm the same pirut behavior
Comment 17 Jeremy Katz 2006-09-13 14:16:36 EDT
Recalculating deps is done properly now and I've made some other UI changes
which address some of the other things here.  If you have further issues with
pirut-1.1.13 or later, please file new bugs -- and one per issue so that they
can be reasonably addressed and closed.

Note You need to log in before you can comment on or make changes to this bug.