Bug 186749 - system-config-display does not offer native resolution
system-config-display does not offer native resolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 20:59 EST by Bernard Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 15:44:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
diff between 800x600 selection and what I generally use (3.24 KB, text/plain)
2006-03-25 20:59 EST, Bernard Johnson
no flags Details
requested xorg log (44.57 KB, text/plain)
2006-03-27 01:46 EST, Bernard Johnson
no flags Details

  None (edit)
Description Bernard Johnson 2006-03-25 20:59:23 EST
Description of problem:
system-config-display does not affer native resolution.  The native resolution
of my laptop is 1440x900.  When I run system-config-display, I am not offered
this resolution, and I have to configure xorg.conf by hand.  I'm attaching the
difference between my xorg.conf and a default (800x600) xorg.conf that I
selected during firstboot.  Sorry about the diff, there is extra cruft in there
because I'm been using the same xorg.conf for awhile now.

Please let me know if there is additional information I need to attach.

I also tried system-config-display --reconfig with no luck.

Version-Release number of selected component (if applicable):
system-config-display-1.0.37-2

How reproducible:
Always


Steps to Reproduce:
1. Acquire my notebook :)
2. Run system-config-display --reconfig
3.
  
Actual results:
No native resolution offered

Expected results:
I would expect 1440 x 900 as that's the physical dispay property.

Additional info:
Comment 1 Bernard Johnson 2006-03-25 20:59:23 EST
Created attachment 126752 [details]
diff between 800x600 selection and what I generally use
Comment 2 Adam Jackson 2006-03-26 20:49:03 EST
please attach your X log file.
Comment 3 Bernard Johnson 2006-03-27 01:46:44 EST
Created attachment 126794 [details]
requested xorg log
Comment 4 Adam Jackson 2006-04-19 13:04:10 EDT
notes to self:

nv driver, correct panel size detection, but no mode line in the default database.
Comment 5 Adam Jackson 2006-08-28 15:44:25 EDT
Should be sorted in rawhide, 1440x900 shows up in the resolution list for me in
1.0.44-1.
Comment 6 Bernard Johnson 2006-08-28 17:44:46 EDT
Sweet.  I did a system-config-display and was able to select the 1440x900 AFTER
I selected "Generic 1440x900 LCD" (This is a laptop).

Before selecting the LCD, I was only offered 800x600 and below.  Is this
something that should (can) be detected automatically?
Comment 7 Adam Jackson 2006-08-29 11:50:43 EDT
(In reply to comment #6)

> Before selecting the LCD, I was only offered 800x600 and below.  Is this
> something that should (can) be detected automatically?

Yes.  I'm working on adding the detected modes from the RANDR extension to that
initial list.  Ideally you should never have to select a monitor type at all.

Note You need to log in before you can comment on or make changes to this bug.