Bug 18675 - KDE Beta5
Summary: KDE Beta5
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-09 06:15 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 08:39:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Qt patch (for 2.2.0 and 2.2.1) (2.67 KB, patch)
2000-10-09 09:15 UTC, Bernhard Rosenkraenzer
no flags Details | Diff

Description Need Real Name 2000-10-09 06:15:46 UTC
compiling KDE beta 5 is without problems
but startkde hangs
docp problems ????

g++ from gcc-2.96 buggy??

Comment 1 Michael Schwendt 2000-10-09 08:39:56 UTC
Argh, Qt 2.2.1 compiles without problems, but Qt designer hangs at the splash
screen. :(

Comment 2 Bernhard Rosenkraenzer 2000-10-09 09:11:49 UTC
Both of these are caused by a bug in Qt.
Qt (more precisely, moc) assumes some things about the C++ ABI that aren't
guaranteed by the standard and that are no longer true with gcc 2.96 (or SUN CC
5.0, for example).

We have fixed this in the Qt 2.2.* RPMs.

I'm attaching the patch.

Comment 3 Bernhard Rosenkraenzer 2000-10-09 09:15:19 UTC
Created attachment 3884 [details]
Qt patch (for 2.2.0 and 2.2.1)


Note You need to log in before you can comment on or make changes to this bug.