Bug 186773 - ATI X850XT PCI-E - Radeon driver failure & FC5
ATI X850XT PCI-E - Radeon driver failure & FC5
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 05:10 EST by Janusz Kawczak
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-22 14:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Janusz Kawczak 2006-03-26 05:10:27 EST
Description of problem:

The option like 'linux resolution=xxxx' are not recognized when doing clean
install on the system with Dell FP 2405FWP and ATI Radeon X850XT PCI-E. 
Anaconda reports corrects video card and monitor type but these have not
effect on the actual display mode.
The picture on the screen is visible on in 75%. 

This problem was NOT present in FC4.

Version-Release number of selected component (if applicable):

FC5, release March 15, 2006, in DVD-bundle.

How reproducible:

By booting from the DVD.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Limited display in the graphical mode during the installation even though
Anaconda recongized the monitor and the video card.

Expected results:

Being able to control the 'resolution' option when booting/installing the system.

Additional info:
Comment 1 Rainer Traut 2006-04-02 12:15:48 EDT
I can confirm this on an Athlon XP3200, X850XT PE AGP card.
The weird thing is, it happens with textmode install, too.

My Viewsonic VX922 monitor tells me a screen resolution of 1280x1023 while I can
see only half of the screen and therefore cannot install.
The installation works fine with FC4.

I suggest changing the priority to high as it seems impossible to install FC5
with user interaction.
Comment 2 Thomas Steudten 2006-04-05 14:06:52 EDT
Maybe same problem like the one from me: Check the Xorg.log file (Xorg -verbose)
for a line like "... (hfreq to high).
See my bug report.
Fix: Add line in Device section of xorg.conf:
     Option      "MonitorLayout" "LVDS, CRT"
     Option      "CRT2HSync" "30.0-90.0"
This is a Xorg problem!
Comment 3 Simon 2006-04-06 07:26:12 EDT
I can confirm that issue.

I have an AMD x2 3800+, 2048MB RAM, ATI X800GTO (PCI-E) and a DELL 2405FWP.

I am able to install FC5 in text mode but after starting X only the 640x480
resolution is possible and if I start under settings the "Display" the whole
system freeze...


(In reply to comment #0)
> Description of problem:
> 
> The option like 'linux resolution=xxxx' are not recognized when doing clean
> install on the system with Dell FP 2405FWP and ATI Radeon X850XT PCI-E. 
> Anaconda reports corrects video card and monitor type but these have not
> effect on the actual display mode.
> The picture on the screen is visible on in 75%. 
> 
> This problem was NOT present in FC4.
> 
> Version-Release number of selected component (if applicable):
> 
> FC5, release March 15, 2006, in DVD-bundle.
> 
> How reproducible:
> 
> By booting from the DVD.
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
>   
> Actual results:
> 
> Limited display in the graphical mode during the installation even though
> Anaconda recongized the monitor and the video card.
> 
> Expected results:
> 
> Being able to control the 'resolution' option when booting/installing the system.
> 
> Additional info:
Comment 4 Rainer Traut 2006-04-06 07:33:03 EDT
Then this is different to mine.
I could not install in textmode,to. There were about 25% missing of screen
contents in grapfical *and* in textmode install.
The only way to install was plugging in an old Radeon 7200 AGP.

After plugging in again the X850 I'm not able to run display config and kudzu.
My system freezes then.
Comment 5 Thomas Steudten 2006-04-06 07:45:24 EDT
I just wondering with update to FC4 and to FC5, why the graphic HW is queried if
I would like to install in textmode. On my older FC3 box I can't update to FC4,
because some python script don't know about my old pci graphic board. So I need
to update myself.
text mode is text mode, don't matter if and what graphic board is installed!
In Redhat 5.1, 6, 7, 9 everything was fine. Why should there always be a GUI to
install or update?!
Comment 6 Thomas Steudten 2006-04-06 07:50:13 EDT
@Simon: I think if you add a line like:
        [Option      "MonitorLayout" "LVDS, CRT"]  <- option
        Option      "CRT2HSync" "30.0-90.0"
to the device section of your xorg.conf (before update maybe)
and comment out the "Load dri" or the "load glx" line, the server starts
with the higher/ normal resolution and don't crashs.
Comment 7 Simon 2006-04-06 10:28:47 EDT
(In reply to comment #6)
> @Simon: I think if you add a line like:
>         [Option      "MonitorLayout" "LVDS, CRT"]  <- option
>         Option      "CRT2HSync" "30.0-90.0"
> to the device section of your xorg.conf (before update maybe)
> and comment out the "Load dri" or the "load glx" line, the server starts
> with the higher/ normal resolution and don't crashs.

Well, doeas this work with a LCD monitor? BTW. the monitor is not the problem.
The probe was correct. The graphic-card is the problem I think...such issues are
really annoying in Linux...(I'm still a newbie..^^)

Comment 8 WAXX 2006-04-14 22:43:17 EDT
I can confirm this issue too...
I have a Dell Dimension 9100 with a Radeon 850XT PE
linux resolution=xxxx doesnt work for me either
a text mode install solved the problem altough slightly annoying...
Comment 9 Mike A. Harris 2006-05-19 00:49:44 EDT
Good news is that I've got 2 Dell 2405FPW displays.  The bad news is that I
do not have an ATI Radeon X850 or similar hardware, nor a PCI-E motherboard. ;/

I have however successfully installed Fedora Core 5 i386 and x86_64 onto an
AMD64 Solo machine with a Radeon 9800 Pro, using DVI-D to the 2405 successfully.
This would seem to indicate that there may be a problem in display
autodetection in the "radeon" driver for newer generation hardware.

Reading the other comments that have been added by others, if using the
MonitorLayout option does indeed workaround this problem, that is a solid
indication that the video driver currently can not autodetect your connected
displays.  In this case, you will need to use this workaround until a newer
driver is available from X.Org that provides correct autodetection support
for this newer ATI hardware.

It is strongly recommended to report this problem to X.Org directly via
http://bugs.freedesktop.org in the "xorg" component, to ensure that all
of the upstream maintainers of the "ati" driver are aware of the problem,
as this will greatly increase the likelyhood of someone being able to
reproduce the issue and diagnose the driver on the same hardware.

Once you've filed a report to X.Org, please paste the bug URL here and
Red Hat will track the issue in the X.Org bugzilla, and review any
fixes that become available for consideration in a future radeon driver
update.

Hope this helps.

Thanks in advance.
Comment 10 Thomas Steudten 2006-05-19 02:11:37 EDT
(In reply to comment #9)
> Good news is that I've got 2 Dell 2405FPW displays.  The bad news is that I
> do not have an ATI Radeon X850 or similar hardware, nor a PCI-E motherboard. ;/
I think the named problems with the r300 comes from the graphics board, not from
the connected displays - so this this will not really help to reproduce it ;-)

> that is a solid
> indication that the video driver currently can not autodetect your connected
> displays.  
That's no all: Without a monitor connected to the 2nd vga port of my card, the
Xorg 7.x ati driver uses the standard-vga setup also always for the internal
LCD. Any higher values are "to high" - complains the ati driver!
  
> It is strongly recommended to report this problem to X.Org directly via
> http://bugs.freedesktop.org in the "xorg" component, to ensure that all
> of the upstream maintainers of the "ati" driver are aware of the problem,
> as this will greatly increase the likelyhood of someone being able to
> reproduce the issue and diagnose the driver on the same hardware.
The problem was not in FC4, but beginning from FC5. So Fedora should be
the best location to report such a problem. It's a bad idea to wait, that
anybody report or fix this at Xorg. You can forward such a problem from you
bugzilla setup easily.. 


Thanks.
Comment 11 Mike A. Harris 2006-05-22 14:27:57 EDT
(In reply to comment #10)

> (In reply to comment #9)
> > Good news is that I've got 2 Dell 2405FPW displays.  The bad news is that I
> > do not have an ATI Radeon X850 or similar hardware, nor a PCI-E motherboard. ;/
> I think the named problems with the r300 comes from the graphics board, not from
> the connected displays - so this this will not really help to reproduce it ;-)

The problem is unlikely to be the graphics board itself, or the problem
would happen in all OS releases.  The problem is almost certainly due
to changes in the "radeon" driver that occured between X.Org 6.8.2 (FC4)
and X.Org 7.0 (FC5).

 
> > that is a solid
> > indication that the video driver currently can not autodetect your connected
> > displays.  
>
> That's no all: Without a monitor connected to the 2nd vga port of my card, the
> Xorg 7.x ati driver uses the standard-vga setup also always for the internal
> LCD. Any higher values are "to high" - complains the ati driver!

Yes, again - general display detection problems in the 7.0 "radeon" driver.
   
> > It is strongly recommended to report this problem to X.Org directly via
> > http://bugs.freedesktop.org in the "xorg" component, to ensure that all
> > of the upstream maintainers of the "ati" driver are aware of the problem,
> > as this will greatly increase the likelyhood of someone being able to
> > reproduce the issue and diagnose the driver on the same hardware.
>
> The problem was not in FC4, but beginning from FC5. So Fedora should be
> the best location to report such a problem.

No, the problem is in X.Org 7.0's "radeon" driver, and not in 6.8.2's.  The
best place to report _all_ X driver problems is directly in X.Org's bugzilla,
unless the problem is reproduceable _only_ on Fedora Core, and even then
it is always a good idea to report it upstream, in case someone else can
actually reproduce it on another distribution.


> It's a bad idea to wait, that anybody report or fix this at Xorg. You
> can forward such a problem from you bugzilla setup easily.. 

X.Org owns and maintains the "radeon" driver.  It's entirely up to you
if you report this issue to X.Org or not, but reporting the problem to
X.Org will ensure that about 10 developers who contribute to the
"radeon" driver frequently will see the problem you are reporting, as
well as all users of all Linux distributions.

Reporting problems like this directly to Red Hat, ensures that only
Red Hat users and developers see the problem which almost certainly
affects all distributions, and it limits the number of X developers
who see the problem to 1 or 2.

If you report the problem to X.Org and paste the URL here, we will indeed
track the issue in X.Org bugzilla, and if a fix becomes available, we will
consider it for inclusion in a future update.




Comment 12 Thomas Steudten 2006-05-23 02:43:16 EDT
Well, using native kernel and xorg from scratch, that's true - you should report
any bug to that source. But FC - you - build there own kernel packages, and it't
not to long ago, that the r300 detection (some PCI IDs) was removed from the
kernel, so that DRI doesn' work any more for X. Reporting this as a bug to xorg,
is not the best. The people need the time to fix real bugs.

I can report this icon bug first, when it's a bug in X, not the kernel. But the
rawhide kernel shows, that this problem is not there any more in this kernel,
but the last ones.
One other point is, that there are new sw packages and new kernel packages and
in the bug list, there's no comment if this bug is fixed in any new (kernel)
package.

I just wondering, that FC disables new R300 PCI-ID detection without testing
this with a R300 PCI-E graphic board.

So, when I build X and the kernel from scratch (x.org/ kernel.org) and this bug
is not there, then this should be reported to bugzilla of FC right?

I know quality issue is hard to track, but please still try it.
I use Redhat/ FC since RH 5.1 for x86 and alpha, and nothing was so buggy 
than FC5 - this does not mean it's FC5 itself, but the components and if you
don't test before shipping - that't BAD.

Thanks.
Comment 13 Janusz Kawczak 2006-05-25 01:19:55 EDT
The card that I originally reported the bug is r480 (not r300). This card is
detected by FC5 but incorrectly. I configured xorg.conf long time ago to give
the desired resolution, except that I do not have 3D support. This is only
available from ATI distribution.

Best, Janusz.

(In reply to comment #12)
> Well, using native kernel and xorg from scratch, that's true - you should report
> any bug to that source. But FC - you - build there own kernel packages, and it't
> not to long ago, that the r300 detection (some PCI IDs) was removed from the
> kernel, so that DRI doesn' work any more for X. Reporting this as a bug to xorg,
> is not the best. The people need the time to fix real bugs.
> 
> I can report this icon bug first, when it's a bug in X, not the kernel. But the
> rawhide kernel shows, that this problem is not there any more in this kernel,
> but the last ones.
> One other point is, that there are new sw packages and new kernel packages and
> in the bug list, there's no comment if this bug is fixed in any new (kernel)
> package.
> 
> I just wondering, that FC disables new R300 PCI-ID detection without testing
> this with a R300 PCI-E graphic board.
> 
> So, when I build X and the kernel from scratch (x.org/ kernel.org) and this bug
> is not there, then this should be reported to bugzilla of FC right?
> 
> I know quality issue is hard to track, but please still try it.
> I use Redhat/ FC since RH 5.1 for x86 and alpha, and nothing was so buggy 
> than FC5 - this does not mean it's FC5 itself, but the components and if you
> don't test before shipping - that't BAD.
> 
> Thanks.


Note You need to log in before you can comment on or make changes to this bug.