Bug 186774 - Focus Issues
Focus Issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 06:21 EST by Simon Goodall
Modified: 2014-06-18 05:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 15:46:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Goodall 2006-03-26 06:21:39 EST
Description of problem:
I am having problems where applications can open new windows and put them on top
of all the others, but they do not necessarily gain focus. Currently I'm having
problems with opening messages in thunderbird. Sometimes the message window has
focus, other times it does not. I have also had similar issues with gaim in fc4
with the message windows appearing, but not taking focus.
In these situations, I cannot click back on the window underneath that has focus
to bring it to the front as it already has focus.

Possibly related is that every time a create a new gnome-terminal from an old
one using ctrl+shift+n, the new window does not have focus. (in fc4 the new
window took focus). This could just be gnome-terminal however.

Version-Release number of selected component (if applicable):
metacity-2.14.0-1

How reproducible:
Sometimes

Steps to Reproduce:
1. Get an application to open a child window. 
2.
3.
  
Actual results:
New window can appear on top of all other but not take focus.

Expected results:
New window should appear and take focus

Additional info:
Comment 1 Lauri Nurmi 2006-04-01 10:39:27 EST
This is probably a duplicate of bug #186308.
Comment 2 Aric 2006-04-05 16:57:35 EDT
I am having similar problems with openoffice.org.  Open two documents in OOo,
and then use the Window menu to select one window or the other.  When I do, the
focus changes to the other window, but that window is not raised.

I am also having trouble with Gaim not being raised when someone sends me a
message.  It is set up to rise to the top when I receive a message, but I think
metacity is ignoring that.

Note You need to log in before you can comment on or make changes to this bug.