Bug 186775 - java.lang.NoClassDefFoundError when starting tomcat5
java.lang.NoClassDefFoundError when starting tomcat5
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: tomcat5 (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Vivek Lakshmanan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 06:25 EST by Stef
Modified: 2008-01-05 08:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 08:14:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
"rpm -qa" on FC5 machine (20.08 KB, text/plain)
2006-03-31 03:50 EST, Stef
no flags Details
Environment of root user (1.42 KB, text/plain)
2006-04-10 08:54 EDT, Stef
no flags Details
with the default java installation (587 bytes, application/x-compressed-tar)
2006-05-09 12:01 EDT, Marco
no flags Details
with the java, installed by the rpm from sun (4.52 KB, application/x-compressed-tar)
2006-05-09 12:02 EDT, Marco
no flags Details
with the java, installed with rpm-rebuild, the rpm from jpackage and the binary from sun (4.55 KB, application/x-compressed-tar)
2006-05-09 12:03 EDT, Marco
no flags Details

  None (edit)
Description Stef 2006-03-26 06:25:54 EST
Description of problem:


Version-Release number of selected component (if applicable):
tomcat5-5.5.15-1jpp_6fc

How reproducible:
Occurs always when starting tomcat5

Steps to Reproduce:
1. # /etc/init.d/tomcat5 start

  
Actual results:
# cat/var/log/tomcat5/cat
Exception in thread "main" java.lang.NoClassDefFoundError: java.util.jar.JarEntry
*** Got java.lang.NoClassDefFoundError: java.util.LinkedList while trying to
print stack trace.



Expected results:
tomcat5 should start and no Java error should show up.

Additional info:
yum update as of 2006/03/26. No changes to config files in /etc/tomcat5.
Comment 1 Rafael H. Schloming 2006-03-27 14:39:55 EST
I was unable to reproduce this problem. Is this a clean fc5 install or are there
any third party packages invloved?
Comment 2 Stef 2006-03-31 03:50:26 EST
Created attachment 127113 [details]
"rpm -qa" on FC5 machine

This contains the output of the command rpm -qa:

# rpm -qa > rpm-qa.txt
Comment 3 Stef 2006-03-31 03:52:26 EST
No, it's a pure FC5 installation from DVD. No extra packages etc. involved.
Please find in the attachment id=127113 the list of the rpm packages that have
been installed. 

I could repeat the error with a fresh installation from FC5 DVD. Don't know how
to get tomcat5 running.
Comment 4 Rafael H. Schloming 2006-03-31 10:42:48 EST
Can you dump your environment?

Also, try /sbin/service tomcat5 start instead of directly invoking the init.d
script, this should run the script in a clean environment.
Comment 5 Stef 2006-04-10 08:53:10 EDT
Enviroment was dumped and attached to this bug.

I tried
# sbin/service tomcat5 start 

but it didn't help in any way:

# cat /var/log/tomcat5/catalina.out
Exception in thread "main" java.lang.NoClassDefFoundError: java.util.jar.JarEntry
*** Got java.lang.NoClassDefFoundError: java.util.LinkedList while trying to
print stack trace.
Comment 6 Stef 2006-04-10 08:54:11 EDT
Created attachment 127544 [details]
Environment of root user
Comment 7 Marco 2006-04-27 07:57:06 EDT
I have the same problem here.

I also get a warning when I try to start tomcat:
(either with service tomcat5 start or with /etc/init.d/tomcat5 start)

# service tomcat5 start
Starting tomcat5: find: warning: you have specified the -mindepth option after a
 non-option argument -type, but options are not positional (-mindepth affects te
sts specified before it as well as those specified after it).  Please specify op
tions before other arguments.

find: warning: you have specified the -maxdepth option after a non-option argume
nt -type, but options are not positional (-maxdepth affects tests specified befo
re it as well as those specified after it).  Please specify options before other
 arguments.

Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JRE_HOME:
                                                           [  OK  ]


I have the exception-message Stef described in his posting and I also get it
when I stop the service tomcat5.

The system is a new installation of FC5 from DVD (iso-file) with the last yum
update done today... 
Comment 8 Marco 2006-05-09 12:01:41 EDT
Created attachment 128794 [details]
with the default java installation
Comment 9 Marco 2006-05-09 12:02:58 EDT
Created attachment 128795 [details]
with the java, installed by the rpm from sun
Comment 10 Marco 2006-05-09 12:03:55 EDT
Created attachment 128796 [details]
with the java, installed with rpm-rebuild, the rpm from jpackage and the binary from sun
Comment 11 Marco 2006-05-09 12:08:45 EDT
I did several tests today.

I tried to start tomcat
- with the default java installed with fedora core
- with the java provided by the rpm from sun
- with a java created by using rpm-rebuld, the rpm from jpackage and the binary
from sun

In all three cases, I couldn't start tomcat. There was no process with the PID
shown in /var/run/tomcat5.pid.
Output and log-files are in the attachments.

Greetings

   Marco
Comment 12 Devrim GUNDUZ 2008-01-05 08:14:20 EST
Cannot reproduce this error with the latest release. Closing.

Note You need to log in before you can comment on or make changes to this bug.