This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 186780 - Banshee dies when attempting to write a CD
Banshee dies when attempting to write a CD
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 08:01 EST by Douglas Furlong
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 11:43:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Douglas Furlong 2006-03-26 08:01:07 EST
Description of problem: When attempting to write audio files from within
Banshee, the application "crashes".

The files are encoded as FLAC, and the disk in the drive is a CDRW,


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Start Banshee
2. Select Audio files to write to CD
3. Tell the system to write to cD
4. Watch it encode the files to be written to cd (or have coffee)
5. Watch it crash :)
  
Actual results:
Application Crashes, the following output it captured from the terminal.

banshee 
Debug: [3/26/2006 1:48:11 PM] (Default player engine) - GStreamer 0.10
Debug: [3/26/2006 1:48:11 PM] (Audio CD Core Initialized) - 
Warning: [3/26/2006 1:48:13 PM] (Could not connect to D-Bus) - D-Bus support
will be disabled for this instance: Object reference not set to an instance of
an object

(Banshee:2784): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling
gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the
data stream to the loader before dropping the last reference.

(Banshee:2784): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling
gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the
data stream to the loader before dropping the last reference.
Building initial DAAP database from local library...
Starting DAAP Server
Scanning library for tracks to update
Done scanning library
Processing track queue for pending queries
Done processing track queue
Warning: [3/26/2006 1:48:25 PM] (Could not verify encoder profile) - Pipeline
profile 'Xing MP3' will be unavailable: GStreamer pipeline 'xingenc' could not
be run

** (Banshee:2784): WARNING **: nautilus_burn_drive_copy is deprecated please use
nautilus_burn_drive_ref() instead

** (Banshee:2784): WARNING **: nautilus_burn_drive_copy is deprecated please use
nautilus_burn_drive_ref() instead
2784: assertion failed "!(connection)->have_connection_lock" file
"dbus-connection.c" line 1758 function dbus_connection_ref
launching command: cdrecord dev=/dev/hdd -v blank=fast 


Expected results:

A nice shiny CD with audio on it.


Additional info:
After the application crashes, I am unable to enter the preferences dialog box,
as this also prompts the system to crash, with the following output.

banshee 
Debug: [3/26/2006 2:02:07 PM] (Default player engine) - GStreamer 0.10
Debug: [3/26/2006 2:02:07 PM] (Audio CD Core Initialized) - 
Warning: [3/26/2006 2:02:08 PM] (Could not connect to D-Bus) - D-Bus support
will be disabled for this instance: Object reference not set to an instance of
an object

(Banshee:2997): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling
gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the
data stream to the loader before dropping the last reference.

(Banshee:2997): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling
gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the
data stream to the loader before dropping the last reference.
Building initial DAAP database from local library...
Starting DAAP Server
Scanning library for tracks to update
Done scanning library
Processing track queue for pending queries
Done processing track queue
Warning: [3/26/2006 2:02:14 PM] (Could not verify encoder profile) - Pipeline
profile 'Xing MP3' will be unavailable: GStreamer pipeline 'xingenc' could not
be run
2997: assertion failed "!(connection)->have_connection_lock" file
"dbus-connection.c" line 3425 function dbus_connection_get_dispatch_status

** (Banshee:2997): WARNING **: nautilus_burn_drive_copy is deprecated please use
nautilus_burn_drive_ref() instead

I have stayed with the default settings in the "burn cd" section.

hdd: HL-DT-STDVDRRW GSA-4166B, ATAPI CD/DVD-ROM drive
hdd: ATAPI 48X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache

Name        : banshee                      Relocations: (not relocatable)
Version     : 0.10.8                            Vendor: (none)
Release     : 1                             Build Date: Tue 14 Mar 2006 07:41:43
PM GMT
Comment 1 Douglas Furlong 2007-03-13 11:43:49 EDT
This environment is no longer available for testing, so I can no longer be of
assistance on this issue. due to no comments from either a developer or from any
other users, I am going to mark this as cantfix

Note You need to log in before you can comment on or make changes to this bug.