Bug 186788 - issues with the installer
issues with the installer
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 09:45 EST by mnemo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 13:24:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mnemo 2006-03-26 09:45:37 EST
Description of problem:
* The blue underlined interdocument links in the release notes does not work
(for instance, nothing happens when I click an entry in the table of contents).

* The release notes does not list FC4 as a Fedora Legancy Project.

* If I select "VIEW RELEASE NOTES" while the files copies themselves the
installer appears to hang at completion because the "CONGRATULATIONS" screen is
hidden behind the release notes (ideally some type of messagebox should appear
here? it was very confusing).

* Before anaconda GUI starts there is a text-based media test etc. This media
test MUST get a proper cancel button. Any process that lengthy should have a
cancel button imho. While installing many FC5 for a lab or something it's very
easy to accidently click TEST instead of SKIP (which is of course undescribably
annoying)

* At the very first stage when the GUI mode is initiated I saw that old horrible
curosr which looks like an X. I believe this is some kind of default cursor for
X windowing system itself or something. Anyway, this cursor reminds me of buggy
slackware installs and it generally sends shivers down my spine. That cursor
make me feel like FC5 is just something built on-top of something really really
out-of-date. I know this is not the case, but feelings are important. It's kind
of the same feeling you got in Windows 95 when you saw DOS booting first and
then the GUI appeared. It's like if it's something bad/old/evil underneath all
that good stuff. Suggested fix: make X use some other modern fresh default
cursor when it starts.

Please split, move and/or forward these issues if needed.
Comment 1 Jeremy Katz 2006-03-27 13:24:27 EST
Filing multiple issues in one bug report makes it very difficult to actually
address things.

* Release notes links -- see the discussion on fedora-devel-list; we're planning
on doing something to address this for FC6
* FC4 is not yet maintained by Legacy
* The release notes buffer during installation is already filed separately
* Mediacheck should always be run.  Cancel doesn't make sense
* Please file a separate bug against X if you think the default cursors should
change.  It's not something that can be changed just within anaconda
Comment 2 mnemo 2006-03-28 08:29:09 EST
Why is there an option to "SKIP" the mediacheck if it should never be used.
There are many cases where you have already completed the media check once for
that particular CD/DVD but you reuse it to install on many workstations. This is
a typical situation when you use the "SKIP" button. After doing say 30-40
installs you typically get a little bit tired and you just keep pressing RETURN
whenever _any_ dialog appears. It's in this situation people accidently activate
the media check and subsequently look for a CANCEL button which does not exists.


I don't understand what you mean by "The release notes buffer during
installation is already filed separately". Can you explain further?

And I repeat what I said earlier:
If I select "VIEW RELEASE NOTES" while the files copies themselves the
installer appears to hang at completion because the "CONGRATULATIONS" screen is
hidden behind the release notes (ideally some type of messagebox should appear
here? it was very confusing).

Note You need to log in before you can comment on or make changes to this bug.