Bug 186814 - X-Server consumes all cpu time in combination with firefox and konqueror
X-Server consumes all cpu time in combination with firefox and konqueror
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
7
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 15:12 EST by Boris Glawe
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 19:11:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot demonstrating the high cpu usage (509.40 KB, image/png)
2006-03-26 15:12 EST, Boris Glawe
no flags Details

  None (edit)
Description Boris Glawe 2006-03-26 15:12:08 EST
Description of problem:

firefox and konqueror causes the X-server to consume all CPU time in some cases:

First examples: xorg binary runs at 100% CPU usage all the time
http://www.mobil-profi.net/index.php?ref=other

second example: clicking any link results in a locked up Destktop for one or two
seconds
http://www.canon.de/For_Home/Product_Finder/Cameras/Digital_SLR/index.asp?ComponentID=164045&SourcePageID=25108#2

In both cases it's the X-Server who uses this big amount of cpu time and NOT
firefox. It's unlikely that the cpu usage is caused by any flash plugins, as the
mozilla suite uses the same plugins but does not have this problem.


Version-Release number of selected component (if applicable):

current releases as they were installed with fc5


How reproducible:
always

Steps to Reproduce:
1. visit pages referenced above
2.
3.
  
Actual results:


Expected results:


Additional info:

Athlon XP 2800+
Asus a8n8x-e Deluxe Mainboard
1GB PC3200 RAM
Geforce FX5200 GPU

I have no proprietary drivers from nvidia installed. Everything is as it was
installed by anaconda.

Except all-in-one-gestures I have disabled all extensions in firefox. As
konqueror does not use firefox's extensions but do have the same problems, it's
unlikely that the problem is caused by any exotic extensions.

I am attaching a screenshot that demonstrates what I mean. Also mind the
system-monitor in the upper panel. The very left blue box shows the cpu usage.
Comment 1 Boris Glawe 2006-03-26 15:12:08 EST
Created attachment 126778 [details]
screenshot demonstrating the high cpu usage
Comment 2 Boris Glawe 2006-03-26 16:23:08 EST
I found out, that blocking all pictures from www.mobile-profi.de minimizes the
problem. There's still a high CPU usage of about 10%, but at least the desktop
is not locked while surfing on pages like these.
Comment 3 Boris Glawe 2006-03-26 17:44:26 EST
The cpu usage is also much higher when clicking normal links.

It takes about 4 seconds at 100% cpu usage on my machine to paint a webpage. The
mozilla websuite does the same job at a fraction of that time. This was not the
case with the same mozilla release on FC4.

I've also installed the binary version of firefox from mozilla.org, which worked
perfectly performant on FC4. It's the same probem here.
Comment 4 Boris Glawe 2006-03-26 18:26:03 EST
I have now installed prebuild binaries from mozilla.org of firefox-1.0.7.

They work as performant as firefox used to before. This is a workaround.

I also tried to modify some X- server parameters:

- decreasing the resolution from 1400x1050 to 1280x1024 didn't change anything.

- decreasing from "millions" to "thousands" of colours made things a little
faster, but didn't eliminate the problem. It's possible that the speed up is an
illusion only ...
Comment 6 Eric Neilsen 2006-03-29 15:39:17 EST
I have the same symptom but from those and other applications. I can get X
window to use 50 - 80% cpu usage when just changing views, tabs, applications,
etc. It doesn't always trigger high CPU usage - but enough to really bother me.

CPU
I have an AMD X2 4200

Video
NVIDIA 6600 -- no native driver.

OS
Linux linuxbox 2.6.15-1.2054_FC5 #1 SMP Tue Mar 14 15:48:20 EST 2006 x86_64
x86_64 x86_64 GNU/Linux

Qt: 3.3.5
KDE: 3.5.1-2.3 Red Hat
KDE Daemon: $Id: kded.cpp 469257 2005-10-10 15:02:57Z coolo $
Comment 7 Matthew Saltzman 2006-03-29 20:42:02 EST
I see the high CPU usage on the first link in the OP, but I don't see the
lockups on the second page.  This is a Thinkpad T41 with an ATI Radeon M7500.
Comment 8 Hesty 2006-04-20 14:58:12 EDT
I have the same problem too. Firefox seems to consume 100% CPU for me all the
time. I have to disable pango for firefox to fix the problem.
Comment 9 Eric Neilsen 2006-04-20 15:34:03 EDT
i finally updated to the native NVIDIA driver and it seemed to fix my problem.
Comment 10 Matěj Cepl 2007-07-18 13:31:58 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 11 Boris Glawe 2007-07-26 07:47:57 EDT
I'm using F7 now. From time to time firefox hangs for one or two seconds while
rendering a page. A difference to before is, that the desktop is not locked
while firefox renders.

A workaround is restarting firefox. This workaround did not help, when I posted
this bug.

The problem was also minimized by installing nvidia's drivers from freshrpms. I
don't now, whether the nv driver is still problematic.

After all, there are some performance problems, but they are not caused by the
X-Server!
Comment 12 Matěj Cepl 2007-07-26 09:19:47 EDT
Please report this issue to Firefox developers by filing a bug report in the
Mozilla bugzilla located at http://bugzilla.mozilla.org.

Once you've filed your bug report to Mozilla, if you paste the new bug URL here,
Red Hat will continue to track the issue in the centralized Mozilla bug tracker,
and will review any bug fixes that become available for consideration in future
updates.

Setting status to "NEEDINFO_REPORTER", awaiting Mozilla bug URL for tracking.
Comment 13 Matěj Cepl 2007-08-29 08:11:35 EDT
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 14 Matěj Cepl 2007-10-11 19:11:46 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.

Note You need to log in before you can comment on or make changes to this bug.