Bug 186920 - Tomcat5 init script messy output
Tomcat5 init script messy output
Status: CLOSED DUPLICATE of bug 179150
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
Depends On:
Blocks: 446866
  Show dependency treegraph
Reported: 2006-03-27 09:40 EST by Kent Baxley
Modified: 2008-08-14 11:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-08-14 11:22:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch to fix output (1.05 KB, patch)
2006-03-27 09:40 EST, Kent Baxley
no flags Details | Diff

  None (edit)
Description Kent Baxley 2006-03-27 09:40:03 EST
Description of problem:

When running "service rhn-satellite stop" a "waiting for processes to
exit" overwrites "Stopping tomcat5:" in the output.

This is probably an output bug, but shouldn't affect the functionality of the
Satellite itself.  

Version-Release number of selected component (if applicable): RHN 4.0.x

How reproducible:

When you run the command service rhn-satellite stop, you'll see, for a
brief second, where the message "Stopping tomcat5:"    [OK] is listed
right after "Stopping httpd:"  However, the "waiting for process to
exit" message immediately pops up and the "Stopping tomcat5" message
disappears.  It's almost as if "waiting for process to exit" overwrites
the "Stopping tomcat5" message on the console.  You're then left with
the following output to the console:

2006-02-13 13:51:35 Monitoring: ===================================
Stopping httpd:                                            [  OK  ]
waiting for processes to exit                              [  OK  ]
waiting for processes to exit
Shutting down taskomatic:                                  [  OK  ]

As you can see, "Stopping tomcat5   [OK]" is no longer there.  The
customer has no confirmation of whether or not the service shutdown OK or
not so there's no way of telling if tomcat5 had any issues during
shutdown, unless the customer closely watches the output during the
rhn-satellite shutdown process.    

This is just a cosmetic bug that the customer would like to see fixed.  

Steps to Reproduce:
1. Run service rhn-satellite stop from the command line.
Actual results:
"waiting for process to exit" overwrites
the "Stopping tomcat5" message on the console. 

Expected results:
"waitig for proces to exit" shouldn't be overwritten

Additional info:

Fernando Nasser says this will be fixed in Bugzilla 179150 in tomcat5 RPMs with
VR greather than 5.5.12-1jpp_12rh to be made available in the next RHAPS errata.

This fix will only be effective when a newer tomcat5 release is incorporated
into the RHN Satelite product, so he suggested filing this bug against Satellite
instead/as well.

See BZ 179150 for details.  Patch is attached
Comment 1 Kent Baxley 2006-03-27 09:40:04 EST
Created attachment 126817 [details]
patch to fix output
Comment 3 Mike McCune 2006-05-02 10:16:18 EDT
moving to rhn420-triage since rhn410 is closed
Comment 6 Shannon Hughes 2007-04-16 17:04:25 EDT
punting until 510
Comment 7 Brandon Perkins 2007-07-20 15:24:09 EDT
Removing 181903 which is closed-wontfix.
Comment 13 Miroslav Suchý 2008-08-14 10:48:15 EDT
Atlhough this patch is evidently present in recent tomcat, this issue still happen in xen console. On normal term (ssh access) it does not happen.
Comment 14 Miroslav Suchý 2008-08-14 11:21:00 EDT
Since we are now using  tomcat5 from rhel (which has been addressed by BZ 179150) I tent to close this as duplicate of that bug. Although some minor issue still persist (comment #13), But I find it very minor. If you insist on fixing it, please feel free to reopen this bug (or most probably the 179150) bug.
Comment 15 Miroslav Suchý 2008-08-14 11:22:29 EDT

*** This bug has been marked as a duplicate of bug 179150 ***

Note You need to log in before you can comment on or make changes to this bug.